Search:

Type: Posts; User: bellscotcv; Keyword(s):

Search: Search took 0.00 seconds.

  1. Re: arbotix robocontroller servos not recognized

    Follow up item,
    For what its worth, I have been able to successfully run the turtlebot_arm demo's and the ControllerGUI.py just fine, even though the terminal.py communication was a bit flaky. Still...
  2. Re: arbotix robocontroller servos not recognized

    mv commands worked as well, and were only intermittent about 10% of the time. So by just trying over and over, I have been able to set all my servo id's but this is just really weird behaviour. Could...
  3. Re: arbotix robocontroller servos not recognized

    OK, the whole thing is even a little wier.der now, but this could be good news.
    When I run the arbotix ros node, and run ls, the light does not stay on solid now.re i
    But it is very intermittent....
  4. Replies
    1
    Views
    3,196

    Re: ros.pde compile error on arduino-0023

    nvm, I found the thread lower on the ros.answers site and it now compiles and uploads perfectly.
    For others that want it handier, here is the fix.
    ...edit...
  5. Replies
    1
    Views
    3,196

    ros.pde compile error on arduino-0023

    Hi,
    I am running arduino-0023 and trying to compile the ros.pde.
    I am using the updated ros_libraries download for the Bioloid library and on compile, I get the following error.
    This is an exact...
  6. Re: arbotix robocontroller servos not recognized

    Hi Fergs,
    So I re-installed everything with arduino-0023. Everything compiles and uploads smoothly.
    However the user led comes on and then stays on and single servo attached is not recognized....
  7. Re: arbotix robocontroller servos not recognized

    Hi again Fergs, I may have found a clue. I re-ran the arbotix_python node and here is what I observed. When I first power on the board. All lights blink on as expected on the FTDI cable and the...
  8. Re: arbotix robocontroller servos not recognized

    Great question and yes, the lights blink when I run the ls command. The problems as with any troubleshooting, is how to get an error that can give you a clue as to the core of the issue. The fact...
  9. Question(s) Re: Problems using PyPose with the Turtlebot Arm

    Thanks, I will give it a try and let you know what happens as I am still stuck as well. Much appreciated.
  10. Question(s) Re: Problems using PyPose with the Turtlebot Arm

    Hi there,
    Were you ever able to see your servo id's and get them working?
    I am having the exact same problem as you are and have posted another thread on this topic as well.
    -Scott
  11. arbotix robocontroller servos not recognized

    Hi,
    I have a fresh install of ubutnu 11.10 running ros fuerte. Following the arbotix stack instructions, I am able to successfully compile and upload the ros firmware sketch. I have power to the...
  12. Re: malloc no declared error on compile of ros.pde

    OK I found the fix from a related posting on a sparkfun site, apparently BYTE has been depricated in the Serial package
    http://forum.sparkfun.com/viewtopic.php?f=32&t=30991
    Thus...
  13. Re: malloc no declared error on compile of ros.pde

    OK I am making progress and this is where I am stuck now. (posted to ros answers as well)

    I am running Ubuntu 11.10 with latest Fuerte install and arduino 0023 I have followed all the...
  14. Re: malloc no declared error on compile of ros.pde

    Thanks for the replies. I will try to to with arduino 0023 on a fresh install of ubuntu 11.10 and ros fuerte and see how it goes.
    Updates to follow! Thanks again!
  15. malloc no declared error on compile of ros.pde

    Hi there. I am trying to get arduino 0018 to compile the ros.pde file (running on Ubuntu Precise) and I am getting the follow errors.
    Any help would be appreciated.

    As an aside question. I...
  16. Replies
    1
    Views
    2,840

    Can NUKE be used with turtlebot arm

    NUKE looks fantastic and I wanted to know if it supports the turtlebot arm. If so, can anyone point me to a how to or tutorial for that?
    Thanks,
    -Scott
  17. Replies
    5
    Views
    4,673

    Re: robot management

    Hi again Peter,
    Finally able to come up for air and look at this as my robotics club I host is over with school letting out.
    I am running into a bit of a snag though as I had to reinstall ubuntu...
  18. Replies
    5
    Views
    4,673

    Re: robot management

    Hi there,
    Patrick Goebel just pointed me in the direction of this thread and I would be happy to help you out, although it will be a day or two before I can take a crack at it.
    To make sure I am...
Results 1 to 18 of 18