Page 6 of 12 FirstFirst ... 2345678910 ... LastLast
Results 51 to 60 of 118

Thread: The Robotis TurtleBot3

  1. #51
    Join Date
    Sep 2010
    Rep Power

    Re: The Robotis TurtleBot3

    Schematic says connector on the OpenCR is Molex 53047-0210 and RTC hardware is integral to the STM32F746 just needing a 32.768kHz crystal. You will need to check the STM32F746 datasheet to confirm the permissible input voltage range on the VBAT pin that is connected to the backup battery header. Datasheet or reference manual should have more on getting useful information from the RTC hardware, unless it is already included in the OpenCR firmware.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"

  2. #52

    Re: The Robotis TurtleBot3

    It seems that ROBOTIS has expanded there FAQ section 23 to include: how to Enable a SSh server on the Raspberry PI.
    Still they have not explained why a working web browser is not supplied.
    Note. For the Turtlebot3, the Master resides on the remote PC vice the robot.
    This makes for easy simulations, as the robot need not be turned on to run them.
    Last edited by LloydF; 01-12-2018 at 10:45 AM.

  3. #53

    Re: The Robotis TurtleBot3

    This is new
    The erle robotics are helping out. The setup.bash seems to be missing so it is probably not ready for the public yet, but soon I am sure.
    Ah, Ha! It is now under Learn on the Web Page.
    Ha, the Link was taken down. I am thinking there are some issues to be worked out here as the applications will not compile.
    And it is back up, but still not working as the setup is in the wrong place, oh I am sure it will get fixed LOL
    Last edited by LloydF; 02-25-2018 at 08:38 AM. Reason: no more link

  4. #54

    Re: The Robotis TurtleBot3

    That seems a little odd. I was updating a new burger with some XM-430's and noticed that you can not ssh into the turtlebot3 if you
    go into headless mode with the raspi-config tool even though you have ssh enabled.
    I was trying it out as I have noticed some latency issues with a gui desktop running on the pi in the past and was going to do some timing tests. (Note) These xm-430's are like the xl-430, just a little faster like 10 rpm LOL but, holy cow, there like a block of aluminum .
    I like it!
    Last edited by LloydF; 01-26-2018 at 09:41 AM.

  5. #55

    Re: The Robotis TurtleBot3

    I am still interested in the waffle, but looks like they are no longer available. My guess is do to the Intel Joule no longer being sold...
    I had the impression that they may be going to one of the UP boards, but so far I have not seen anything...

    Wonder with the SSH. Maybe there is something running that is eating up to much of the CPU resources?

  6. #56

    Re: The Robotis TurtleBot3

    I think it is the opposite in this case. The only resource hog is the system updater which has to time out before you can do a apt-upgrade, which works, Yea! I saw you trying to get them, to get cracking on a release for the up2 but that was months ago.
    I am setting up my burger with a nice usb camera and using the NVIDIA TX2 as the
    remote PC since it does all the heavy computation and
    has some nice help for booting to a ssd disk drive an getting started with some caffe stuff. So off to the races.....
    Last edited by LloydF; 01-23-2018 at 01:24 PM.

  7. #57

    Re: The Robotis TurtleBot3

    Oh, Oh I noticed that the turtlebot3_applications will not compiling.
    (Note) The errors were 2, one was the missing laser-filter, then there is a programing error in the Panorama code.
    I am thinking it will get fixed soon, but for now I cannot get the applications to compile.
    Last edited by LloydF; 01-26-2018 at 09:08 AM. Reason: a short fix

  8. #58

    Re: The Robotis TurtleBot3

    At this point I am just curious what their plans are... The Nvidia stuff could be interesting... But would settle for some default configuration.

  9. #59

    Re: The Robotis TurtleBot3

    My only question is how are they showing these application demo's when the applications will not compile?
    Are there some fakers going on here?

  10. #60

    Re: The Robotis TurtleBot3

    Wondering: does it not compile on the NVidia? Does it compile on the RPI3?

    Maybe differences in system files?

    Or maybe someone forgot to update some other files they changed and/or included... Just guessing... I have been known to do something like that from time to time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Robotis OpenCM9.04 need help.
    By ErikVH in forum Robot Computers
    Replies: 6
    Last Post: 11-19-2014, 11:25 AM
  2. Robotis Task
    By 2fast4-u in forum Software and Programming
    Replies: 0
    Last Post: 08-23-2014, 07:36 PM
  3. Robotis OpenCM9.04 need help.
    By Hari in forum Robot Computers
    Replies: 38
    Last Post: 03-10-2014, 12:21 PM
  4. The New Robotis CM-900 board is now out!!!
    By Gort in forum Arbotix, Microcontrollers, Arduino
    Replies: 7
    Last Post: 07-16-2013, 11:42 AM
  5. Robotis CM-700 Shell ?
    By Ron in forum Arbotix, Microcontrollers, Arduino
    Replies: 7
    Last Post: 11-15-2012, 07:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts