Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: AX-12 led light constant on, error?

  1. #1

    Question AX-12 led light constant on, error?

    Hi.
    I had an contact issue that i tried to fix for one of my ax12.
    suddenly the led lights up constantly.
    After that i can`t communicate with it.
    Whenever I power it up the led comes on constantly.

    I tried the dynaManager and the dynamixel wizard.
    The dynaManager cant read the fault servo, but it reads those who are fine.
    Dynamixel wizard wont show any servos... should I use some sketch?
    I`m using the arbotix-M and a USB Xbee interface
    Last edited by Lynlimer; 06-25-2017 at 10:33 AM.

  2. #2

    Re: AX-12 led light constant on, error?

    Whenever I power it up the led comes on constantly.
    When you said you "tried to fix" an issue, what did you do?

    It sounds to me like you broke it. LED going on right away means the servo detects something wrong, and goes into alarm. (Or it means you shorted up the LED control.)

    For the more expensive Dynamixels, it's typically worth it to send them back to Robotis for service/replacement of broken parts, but the AX-12A costs less than their service cost, so you'd probably want to buy a new one.

  3. #3

    Re: AX-12 led light constant on, error?

    The pins inside the contact where to wide, that made the servo turn on and off all the time.
    I took out the pins. One at the time, and pinched them more narrow. it was the second one i fixed. (poor cables in the kit.)
    this was all to tibia servos, and there was a femur servo that it happend to (in series to the tibia servo that had an issue)
    quess it could not handle the contact issue... the servo lasted for an our of use :P

  4. #4

    Re: AX-12 led light constant on, error?

    Again as I suggested in the other thread, you might contact Trossen to see if they or Robotis will resolve this as a warrantee issue.

  5. #5

    Re: AX-12 led light constant on, error?

    Separately, if you think the connection is intermittent, some contact paste might help with that, without having to mechanically mash things.
    http://amzn.to/2tNcQpC

    It's also possible the servo was defective from the factory if this is a new kit. If so, warranty replacement would be your best bet.
    Or it's possible you accidentally shorted the signal wire to the voltage wire, which would blow up the transciever chip in the servo, and make it not able to communicate. (The symptoms you indicate sound a bit like that, to me.)

  6. #6

    Re: AX-12 led light constant on, error?

    its a common issue with that kind of contacts. usually they get like this after years of use.
    nothing is mechanically mashed, it kind of a delicate work.
    I took one pin at the time, for no chance of crossing. and I never powered it up with loose pins...
    There`s 3 more of the 100mm wires that has the same issue.

  7. #7

    Re: AX-12 led light constant on, error?

    Quote Originally Posted by KurtEck View Post
    Again as I suggested in the other thread, you might contact Trossen to see if they or Robotis will resolve this as a warrantee issue.
    I sendt a mail at Monday, and a reminder at Thursday. today its Friday, and I still haven't got an answer...
    Nothing in my junk mail either...

    Quite disappointed at Trossen...

  8. #8

    Re: AX-12 led light constant on, error?

    The delay may not be Trossen; Trossen has to wait for Robotis in turn. Or maybe the warranty guy is out on vacation this week; it is summer and next week is 4th-of-July week. There are tons of possible explanations for taking a few days to answer.

    It may be easier to communicate straight to Robotis, because that's typically where the servos go, anyway:
    http://www.robotis.us/shipping-returns-warranty/
    [email protected]

    Look especially at section 12:

    12. RMA Process:If you would like ROBOTIS to evaluate/repair your items or if you would like to return your items for an exchange, refund, or replacement, you must do the following before sending your items to us:

    1. Contact the retailer from where you purchased and ask for support. If your retailer is unable to help, they will go through the RMA process on your behalf or guide you to the RMA form.
    2. You must go through the appropriate product self-checklist and identify the error code associated with your items.
    3. You must then fill out the following RMA form with the relevant information, including the error code. If there is no error code, please choose N/A. Please contact [email protected] if you cannot access the RMA form.
    4. Once you have filled out the RMA form, please wait until a representative from ROBOTIS contacts you and provides you with an RMA#. Upon receipt of your RMA#, you may ship your items to us. ROBOTIS has the right to refuse your shipment if you have not been issued an RMA#.

  9. #9

    Re: AX-12 led light constant on, error?

    That being said, hobby robotics is a learning experience, and there are some unplanned costs that will show up.
    (Ask me about that time I forgot to unplug the LiPo battery and it drained down to 0V and could not be rescued...)
    If you want to keep working right now, buying one AX12a will get you going again for a reasonable cost; if it turns out you get a replacement for the defective servo, you can keep that in reserve for when some other servo dies. (Or mount it in as something that can aim a laser pointer or head camera or whatever :-)

  10. #10

    Re: AX-12 led light constant on, error?

    Thanks
    You are right! I bought a new one from ebay!
    But I still think trossen could give a notice whenever they cant answer their mail...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dynamixel error - no torque + red light blinking
    By panthallion in forum HR-OS1 Development and Discussion
    Replies: 16
    Last Post: 05-01-2015, 07:16 AM
  2. Blinking Red Light AX-12A
    By deathwiz in forum DYNAMIXEL & Robot Actuators
    Replies: 11
    Last Post: 12-03-2014, 12:21 PM
  3. ax12 and constant led
    By 2fast4-u in forum Humanoids, Walkers & Crawlers
    Replies: 8
    Last Post: 09-08-2014, 05:06 PM
  4. Question(s) Compiling Error with Arduin IDE / Pypose : could not read servo error
    By lweydert in forum Software and Programming
    Replies: 3
    Last Post: 03-27-2013, 08:16 AM
  5. Sound and light installation
    By bianca in forum Project Showcase
    Replies: 1
    Last Post: 02-21-2007, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •