Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: USB2AX seems broken

  1. USB2AX seems broken

    Hi folks,

    I am just getting started with Dynamixel actuators. I bought a USB2AX and two AX-12A actuators and built a "Y" cable using the Trossen Robotics 12-volt adapter. I tested the "Y" cable extensively for polarity and proper voltage. I then connected the servos and as expected, the red light comes on for about 1 second then turns off.

    Problem: I tried the ROBOTIS software under Windows, and the Python/Tk dynamixel_hr utility. In all cases, no servos were found.

    I then disconnected everything from my USB2AX and scoped the data line as I scanned for servos. The result was per the following photos -- some weird blips of about 0.1V, but nothing that looked like a real signal.

    Do I have a dead USB2AX? How could it have died? What could be the issue?

    Kind regards,

    Ihab Awad

  2. #2

    Re: USB2AX seems broken

    Sorry, I am not a python person, so may not be much help. Also I have not used the USB2AX much with windows, mostly with Linux.

    But with Saleae logic analyzer you might try using a digital input instead of analog input, probably as fast as your LA allows. Could not tell from pictures which one you have... If one of the PRO (USB3) versions, you might want to update to latest release as the doubled the speed of them...

    You should get a 1MBS Serial signal, where you should be able to see the packets using the Serial input filter... (I also have a Dynamixel message input filter up on Github...)

    With the USB2AX, to test communications, I often will try to talk directly to it. It has the ID of 0xfd and you can query values like it's id, version number...

  3. Re: USB2AX seems broken

    Got it -- thanks. Will try the digital input and see if that works. For what it's worth, I tried running the firmware updater for the USB2AX successfully and the status LEDs come on just fine. I'm skeptical that my logic analyzer will find digital data there given that the blips are only a tenth of a volt at best, but I'll give it a whirl.


  4. #4
    Join Date
    Sep 2010
    Rep Power

    Re: USB2AX seems broken

    Did you give the AX-12 different IDs prior to connecting them together on the buss? The default ID is 1, so connecting multiple brand new servos will result in collisions as every new servo has the same ID.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    gives free advice only on public threads

  5. Re: USB2AX seems broken

    Thank you tician -- I actually didn't think of this at first ... then I did, and I was using just 1 servo connected to the USB2AX at a time. Still no recognition of that servo.


  6. Re: USB2AX seems broken

    [ I think one of my replies got lost - sorry if this is a duplicate. ]

    Thanks KurtEck -- I will try it in digital mode. I am a bit skeptical since the blips were only about a tenth of a volt, and generally when I scope an I2C or other digital bus in analog mode I see real waveforms.

    I should also add that:

    * My USB2AX LEDs come on properly
    * I ran the Xevlabs firmware update process and that worked just fine

    Also, judging from the USB2AX schematic, even if I mis-wired it (which is unlikely since I was very careful), it should tolerate intermittent application of 12V to the DATA line. So it's weird that I'm getting no signal. On the other hand, again from the schematic, it seems like the digital outputs are pretty much directly from the microcontroller, so I wonder if I have one with a bad microcontroller? It's certainly something I've done myself -- fried inputs and outputs of Arduino chips....


  7. #7

    Re: USB2AX seems broken

    Not sure what else to suggest, other than if you have something like a RaspberryPI then you could try it out on Linux and see if it is working.

    The difficulty is that without seeing what the USB2AX is receiving on the USB side it may be hard to know what is going on.

    At times now, I hack into USB cables and hook up the signal+ and - pins with the logic analyzer. (harder to do with USB2AX. I have mucked up some extension cables to try it out. You then use the USB LS/FS analyzer set to high speed mode (on my Logic Pro 8) and then you can see the packet data...

  8. Re: USB2AX seems broken

    I'm sorry about that.

    Your Y cable looks all right, your troubleshooting steps are spot on, and as you noticed 12V on Data line is not going to cause issues on a properly assembled USB2AX (even for long period of time, or even with like 15V).

    Your capture showing the Data line is worrying though. I don't think anything is actually fried (the amount of abuse ATmegas can sustain is crazy) but it could be a bad solder joint on the MCU (on the TX pin, meaning that on DATA you would only see the noise generated on RX).
    Or on the resistor between TX and DATA. Or something with the very small zener diode. Please note that the schematics in the support website is slightly out of date, the one for your unit is in the git repository.

    Every unit is tested but something could have happened. I would say if you're feeling confident with an iron, cut the plastic cover and try heating the relevant solder joints with some flux (hot air can do it too but big risk of melting the dxl connector). I can guide you on identifiying the exact spots if reading the Eagle files is not your cup of tea.
    If you just want something that works, ask for a replacement (or PM me if you're not in a hurry and I'll get you one).

    Personal blog:
    USB2AX documentation:

  9. Re: USB2AX seems broken

    Thank you Xevel -- I will try your soldering trick when I get home tonight and report back. SMDs the world around cringe the moment I pick up a soldering iron, but we'll see.... Kind regards, -- Ihab Awad

  10. Re: USB2AX seems broken

    Ok, I did some tooling around this evening and here's the scoop --

    * I got the Eagle files from and opened them.

    * Using the schematics as a guide, I went over all the connections in the path between the MCU and the outgoing DATA line with a soldering iron and solder. The R3 terminals on the South side seemed a bit sketchy but I could not be sure since I do not have access to an inspection 'scope at home.

    * I scoped the DATA output while scanning again and got the same weak result, albeit a slightly different-looking one!

    * For one brief shining moment, all of a sudden, the output became a beautiful square wave! It was gorgeous! Like a sunset over the ocean, but with puppies.

    * Quick, I said! Plug in my AX-12A servo and rescan! But alack, the servo was not found....

    * ... and upon scoping the output again, it appeared it had returned to its weakling ways.

    I suspect (a) that there is a hardware problem with my USB2AX; and in fact (b) one that I am not qualified to fix!


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hexapod broken?
    By MadBot in forum Humanoids, Walkers & Crawlers
    Replies: 10
    Last Post: 06-15-2017, 07:16 PM
  2. USB2AX and ROS
    By dejamzo in forum ROS - Robot Operating System
    Replies: 4
    Last Post: 10-19-2015, 08:51 PM
  3. Broken part -- needing replacement
    By jveejay in forum HR-OS1 Development and Discussion
    Replies: 1
    Last Post: 06-10-2015, 05:16 PM
  4. links to HR-OS1 docs are broken.
    By bg404 in forum HR-OS1 Development and Discussion
    Replies: 1
    Last Post: 05-11-2015, 11:56 AM
  5. USB2AX v3.1
    By Xevel in forum Arbotix, Microcontrollers, Arduino
    Replies: 25
    Last Post: 04-08-2013, 03:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts