Page 2 of 5 FirstFirst 12345 LastLast
Results 11 to 20 of 41

Thread: Phantom_Phoenix on OpenCM 9.04...

  1. #11
    Join Date
    Jan 2008
    Norway, Stavanger
    Rep Power

    Re: Phantom_Phoenix on OpenCM 9.04...

    Thanks Kurt for the link of the great overview, didn't know about that.
    Been lots of outdoor stuff at my place too. The summer came early this year.
    Kåre Halvorsen aka Zenta
    Zenta's YouTube channel
    Zenta's Blog
    Zenta's Instagram

  2. #12
    Join Date
    Apr 2013
    Boston, MA
    Rep Power

    Re: Phantom_Phoenix on OpenCM 9.04...

    If anyone needs an OpenCM9.04B, i have a one brand new in sealed packaging i doubt i'll get to using. Just send me a PM.

  3. Re: Phantom_Phoenix on OpenCM 9.04...

    Hi Kurt, I've been working on replacing the Arbotix board on my PhantomX with an OpenCM 904 following your suggestion on another thread. I bought a 904a (no connectors) and the connector kit. I then soldered on 4 x AX TTL connectors and will use the Trossen power hub for the extra AX connectors needed. Like you I considered the OpenCM 485 expansion board but realised it wasn't necessary. I'll power the 904 via the barrel connector on the power hub which then connects to the 904 via a AX style ttl cable.
    I had the same problem programming the 904 via the Arduino IDE in that I needed to do the firmware recovery by holding the user button down when connecting the usb. Once that was done it was fine and I like being able to program via the usb. Much less hardware required.
    My next step will be to connect an Xbee to the OpenCM9.04’s 4-pin communication port which uses Serial2(USART2). I bought a cable for this and will cut off one end and solder it to a Sparkfun Xbee Explorer regulated board that I have on order.
    I'll be able to try out your OpenCM9.04 Phoenix soon. Did you have any issues with it I should be aware of?

  4. #14

    Re: Phantom_Phoenix on OpenCM 9.04...

    It has been a while since I have tried running it.

    Although currently getting ready to try out the code again up on

    But will be verifying that the code works for the OpenCR board. I have done some changes to their Arduino core code for both the OpenCM and OpenCR and I am wanting to try out the OpenCR to hopefully verify I have not busted anything...

    Side Note:
    For both of these platforms I have been playing around with changing how their SerialX.write(...) functions work. Currently released code blocks on each call until the write completes... I now have versions of code that like most platforms don't block... I have taken two different approaches with these changes, and have different Pull Requests for each. My guess is they will prefer the approach I did for the OpenCR, which I have done some testing and can run the DXL buss at 4mbs with an XL430-W250 servo.

    Back to question:
    As mentioned the 485 board is not necessary, although I have a few of them now. For XBee I used my own adapter as the boards run at 3.3v, I did not need the extra support of the 485 board. Although I might be for the 485 board if they sold a 904 board that already had pins installed, so users would not need a soldering iron... Likewise I have a couple of power hub with extra XL320 connector, that hopefully you could use a standard soldered 904a board, then use xl320 jumper cable to hub and then plug in your AX or XL430 like servos in...

    Code wise the code up there was originally AX servos only, but I was in progress of supporting XL servos as well. I have not tried it in awhile, not sure what state that part is in, was waiting until I had an XL hex to play with... Once I have an XL based hex, some of the underlying code will probably change to use more of the smarts of the newer servos.

    Let me know how it goes! I will try to help out if you run into anything.


  5. #15

    Re: Phantom_Phoenix on OpenCM 9.04...

    Thought I would mention, I have setup the PhantomX 3 with an OpenCR board. I am using it to test out some of my changes OpenCR Arduino code base. I have now tried it using the Commander having the XBee hooked up two different ways. The first way was with the XBee adapter I was using on the OpenCM9 board (Serial2), and the 2nd way was with an Arduino XBee shield (Serial1).

    The basics appear to be working

    The OpenCR board has some power management built in, which I believe turns the power off to the servos when the battery gets too low. Also has a buzzer...

    Click image for larger version. 

Name:	IMG_0399.jpg 
Views:	157 
Size:	125.6 KB 
ID:	7334

    So far it looks like my underlying changes to Serial are working. Changing SerialX.write calls from blocking to non blocking (DMA)...

    Next up verify Turtlebot3 works...

    Edit: Actually looks like I need to do the power management. It does have a voltage divider builtin 47K/10K resistors... Their Turtle Rox code automatically handles it. If voltage gets bellow some threshold it turns on LED, still lower Buzzer and I believe lower yet turns off power to servos....
    Last edited by KurtEck; 09-30-2018 at 07:13 PM.

  6. Re: Phantom_Phoenix on OpenCM 9.04...

    Click image for larger version. 

Name:	IMG_6080.jpg 
Views:	149 
Size:	111.2 KB 
ID:	7335
    Making some progress with the OpenCM. I've mounted it on a couple of standoffs so I can alternate between it and the Arbotix as I work through the migration to the new board. I've got my Lidar Lite V3 connected and working via a PWM interface. It avoids using the I2C interface which is shared with UART3 on pins 24,25. (I don't want to sacrifice a Serial port). I'm powering the board from the TTL hub which works fine. I ran the search for servos code tonight and it finds all 18 servos ok. I'm now waiting on delivery of a Xbee board so I can connect it to the Comms port on the OpenCM. Will try the Phoenix code then.
    Note the Voltage monitor which I have connected to one of the TTL 12V pins so I can keep an eye on the voltage without having to unplug it when I switch it off. A good visual reminder to turn the robot off too.

  7. Re: Phantom_Phoenix on OpenCM 9.04...

    Ok, received the Sparkfun XBee Explorer Regulated board. I then cut off the end of the OpenCM904 comm port cable and soldered it to the XBee Explorer using the 3.3V pin on the Xbee as the OpenCM904 outputs 3.3v on the comms port. I've now got the OpenCM904 modified Phoenix code working and the Phantom seems to respond normally to the Commander controls. The only thing I noticed was that the code was set to port 3 for the OpenCM904 option. Not sure why but I changed that to port 1 and the servos came to life. So the change from Arbotix to OpenCM 904 seems to be pretty straightforward. Looking forward to utilising the extra serial ports. I've got an extra pair of Xbees so might use them for the Serial Monitor.

  8. #18

    Re: Phantom_Phoenix on OpenCM 9.04...

    Sounds good. Serial1 is used for DXL servos connected directly to the 904 board. Serial3 is used if you have your board connected to a RS485 expansion board. I have a few of the expansion boards, so been doing more of my testing using them, which is why the code was left on 3...

    Note with Serial ports. Currently the released Arduino code base for OpenCM boards, all Serial.write like calls are blocking. That is the code will wait until the transfer completes before it continues.

    I have a version of code that makes these calls unblocking... Likewise for OpenCR. I have a version of it as well that does not block. But I did it differently internally and will probably update the OpenCM code to be more like what I did for OpenCR... Have PR for both and working with Robotis... Will see if they will be able to take them or not.

    But if you wish to play around, my Forks/branches are up on my github.

    There is also some instructions on how I have my Arduino setup such that I build with either the released Arduino code base or with my own development code base... up on

  9. Re: Phantom_Phoenix on OpenCM 9.04...

    Ok I hooked up 2 XBees, one to the PC and the other wired to pins D24/D25 on the CM9.04 as I'm intending to use this as a wireless serial monitor. However found the following
    - I get no output in the Arduino serial monitor when connected to the new port on the PC when using Serial3.print
    - I tried connecting the RX and the TX on the UsartBee USB to FDTI convertor (without the XBEE plugged in) but still get no output so I don't think it's an XBee issue
    - I can get output in the Arduino serial monitor if I use Serial.print or SerialUSB.print via the USB port
    - I can get output in the SM if I use Serial2.print with the XBee connected to the Comm port on CM 9.04 (I'm normally using this for the Commander controller which also works fine)
    - I tried connecting my Salae to pins D24/D25 but I don't yet understand what I'm seeing. (which protocol should I use?) I see level changes when it's active but can't decode it to the text I'm printing yet.

    So is there something special I need to configure for this UART apart from the Serial3.Begin(38400)? I see that these pins can also be used for I2C so does that mean I need to configure it somewhere as a standard serial port? I've searched the doco but can't find anything specific to this.


  10. Re: Phantom_Phoenix on OpenCM 9.04...

    Update to this. I got the Logic Analyzer worked out and pin 24 is outputting the correct text so the code and the board are correct. It must be in the serial connection back to the PC. I'll keep looking.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OpenCM 9.04 iwdg
    By lpala in forum Arbotix, Microcontrollers, Arduino
    Replies: 0
    Last Post: 07-28-2017, 12:32 PM
  2. OpenCM 9.04, best way to beep?
    By jwatte in forum DYNAMIXEL & Robot Actuators
    Replies: 10
    Last Post: 04-09-2017, 12:11 PM
  3. Question(s) Is my OpenCM 9.04 dead? Or do are my AX-12A servos?
    By corot in forum DYNAMIXEL & Robot Actuators
    Replies: 4
    Last Post: 10-31-2016, 04:54 PM
  4. Acceleration implementation on OpenCM?
    By jomo in forum DYNAMIXEL & Robot Actuators
    Replies: 4
    Last Post: 05-19-2016, 07:18 AM
  5. OpenCM IDE (Ubuntu 14.04)
    By rasheinstein in forum Arbotix, Microcontrollers, Arduino
    Replies: 2
    Last Post: 04-12-2016, 12:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts