Results 1 to 5 of 5

Thread: No Arbotix connected - Dynamanger14

  1. #1

    No Arbotix connected - Dynamanger14

    Hi

    I have ran into a bit of dead end trying to get Dynamanager to recognize my Arbotix-m controller. I can see and write to the controller with Arduino 1.0.6 and 1.8.5 (I started with 1.8 but backtracked to ensure it was not the cause) When I get board info under 1.8 the board is returned as "unnkown" even though it is listed in the boards. I have tried on a number of machines and across Linux and Windows with no luck.

    Many Thanks

    Stuart

  2. #2

    Re: No Arbotix connected - Dynamanger14

    Could the problem stem from the firmware on the Arbotix-m not having been correctly installed before shipping? would it be possible for someone who has this board to post the output from "about board" on a resent Arduino ide. This would help you asses the state of the board I have. Are there any examples of setting the AX-12As ID through the Arduino IDE anyone knows off. This could part resolve the issue as at least I would be able to check all 18 AX-12As are working before I the Hex together.

    Many thanks again

    TwoBarFoo

  3. #3

    Re: No Arbotix connected - Dynamanger14

    I am not really sure what program they may pre-program the Arbotox-m with...

    So if you expect some specific program on it, you need/want to run, then probably best to download it to the Arbotix-m.

    As for programs that can set the IDs...

    I have my AX Test program that I sometimes use to do this: https://github.com/KurtE/AX12_Test/

    It is a hodgepodge of simple commands, including one to set an ID...

  4. #4

    Re: No Arbotix connected - Dynamanger14

    KurtEck

    Thanks for the response, as you have no doubt already surmised I am new to embedded systems, I have presumed the board had "soft" functions beyond the silicon, From your response I read that I am was mistaken. As for you github, It is somewhat of a treasure trove. It is going to take me a while before I even have a rudimentary understanding of much of it, I know I will be raising many a cold beer to you in gratitude over the coming months... starting right now so many thanks. The test code gives me a great into into the AX-12s.

    I see you have replaced 1 with 19. I take it this is to resolve a default reset condition so I will follow suit here.

    Again thanks for all you've shared, the barrier to entry would be much higher without it.

    TooBarFoo

  5. #5

    Re: No Arbotix connected - Dynamanger14

    Hey, just to let you know your code was great and after a few changes (I was using the standard library) I got everything up and running and Jeffrey took his first steps today. Going to spend the next few days of free time I have reading through your past threads and trying to understand some of where others have been before I decide where I'm going to take him.

    At the moment I plan on adding a UP, R200, Mic, speaker, and some wheels.

    Thanks again for the assistance

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) How to power AX-12A servos connected to an USB2AX?
    By corot in forum DYNAMIXEL & Robot Actuators
    Replies: 6
    Last Post: 02-20-2017, 06:01 PM
  2. Question(s) Can Arbotix Pro easily replace the Arbotix-M in my robot?
    By NSz in forum Arbotix, Microcontrollers, Arduino
    Replies: 1
    Last Post: 05-23-2016, 02:12 PM
  3. Question(s) ArbotiX with LabVIEW: Low-level ArbotiX Commands?
    By vogonpoet42 in forum Software and Programming
    Replies: 2
    Last Post: 03-01-2013, 10:25 AM
  4. Question(s) Can I use Robotis Dynamixel SDK to control dynamixels connected to CM-510
    By nsmoly in forum Software and Programming
    Replies: 6
    Last Post: 05-28-2012, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •