Results 1 to 4 of 4

Thread: Cannot connect to Dynamixel XM430-W210-T by USB2Dynamixel adapter

  1. Cannot connect to Dynamixel XM430-W210-T by USB2Dynamixel adapter

    Hello,

    I have a problem with Dynamixel XM430-W210-T. I deliver power to Dynamixel via SMPS2Dynamixel and it is connected to USB2Dynamixel adapter. I set the adapter to TTL. Last time I could connect and control Dynamixel motor using Dynamixel Workbench software (http://wiki.ros.org/dynamixel_workbench) without any problem. Yesterday I tried to control the motor but the software couldn't find the dynamixel. I tried to connect with baud rate 57600 and 2.0 protocol version as before. Is there any approach to debug the dynamixel connection? Do you have an idea what can be wrong?

    Best Regards

  2. #2

    Re: Cannot connect to Dynamixel XM430-W210-T by USB2Dynamixel adapter

    First, hook up an oscilloscope to the TTL bus to make sure that the TTL UART signal is actually correctly generated.
    If not, you need to debug the adapter, the USB drivers, and so forth.
    Second, Try scanning with a different baud rate? 1000000, 2000000, 9600, and some other common baud rates?
    Also, you could always try recovering the firmware on the servo, as that will typically reset the baud rates.

  3. Re: Cannot connect to Dynamixel XM430-W210-T by USB2Dynamixel adapter

    Quote Originally Posted by jwatte View Post
    First, hook up an oscilloscope to the TTL bus to make sure that the TTL UART signal is actually correctly generated.
    If not, you need to debug the adapter, the USB drivers, and so forth.
    Second, Try scanning with a different baud rate? 1000000, 2000000, 9600, and some other common baud rates?
    Also, you could always try recovering the firmware on the servo, as that will typically reset the baud rates.
    Thank you very much for your response.

    I checked the adapter with logic analyzer and it seems to be ok. I would like to point out that I could find and control this servo two weeks ago. Is it possible that the dynamixel could change baud rate by itself? Could you provide more info about recovering the firmware? I thought that I need to find and connect to the servo before recover its firmware.

    Best Regards

  4. #4

    Re: Cannot connect to Dynamixel XM430-W210-T by USB2Dynamixel adapter

    The firmware recovery in a tool like Dynamixel Manager uses a special fixed baud rate protocol that the servo starts out with when it powers on. This is why the recovery process is "first connect to the adapter, then power cycle the servo" -- the servo sends out a special "I'm starting up, is there recovery?" packet, which the adapter listens for. If it sees it, it responds back to the servo, and new firmware is uploaded, with a know fixed baud rate. If the servo doesn't see the response, it times out into regular configuration.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Question(s) Delete
    By JimiH in forum DYNAMIXEL & Robot Actuators
    Replies: 0
    Last Post: 05-11-2016, 08:55 AM
  2. Buying a USB2Dynamixel Adapter
    By EpicZa in forum Arbotix, Microcontrollers, Arduino
    Replies: 9
    Last Post: 06-12-2015, 12:28 PM
  3. Wanted: Dynamixel MX-64T, MX-28T, USB2Dynamixel
    By OOrmOnIzArGoR in forum Garage Sale
    Replies: 3
    Last Post: 12-31-2014, 08:46 PM
  4. 18 Dynamixel Ax-12A with ArbotiX/Arduino - How to connect the dynamixel?
    By Snuuq in forum Arbotix, Microcontrollers, Arduino
    Replies: 20
    Last Post: 02-14-2014, 12:29 PM
  5. USB2Dynamixel + Zig2Serial Adapter Vs. XBee USB Dongle
    By dnhan in forum Software and Programming
    Replies: 1
    Last Post: 01-08-2013, 06:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •