Results 1 to 8 of 8

Thread: Hexapod Randomly Freezes

  1. Hexapod Randomly Freezes

    I've got a Hexapod MK3 which has developed a tendency to freeze at random. As I had made some changes to the Phoenix code I went back the the original Arduino 1.6 Phoenix beta code with Kurts Phantom-Phoenix code. However right now after trying the robot with the Phoenix code it froze during a body rotation and I've got Kurt's AX12-Test sketch loaded and none of the servos are returning any values. The voltage test just prints 65535 and it can't find any servos. I know the voltage is ok as I'm reading 12.3v on one of the TTL connectors and the servos are in a fixed position so they are getting power.

    While I was typing this it has come back to life after a couple of power cycles and after a couple of retries I get all the servo positions and it responds to servos off and servos center ok with a system voltage of 12.3 so all normal again.
    I'd had this problem on and off for several weeks and have tried many things to isolate the issue but can't get a handle on it. I've even gone back to Arduino 1.0 and tried a NUKE sketch which seems to work better but I've still seen freezes under that configuration too. The only time recently it's been reliable was an extended test with the Nuke liadar demo sketch loaded as I have a Lidar lite mounted. (I haven't disconnected that yet but may do so as a next step but can't imagine why that would be an issue. It's connected to the I2C pins and works fine)
    I've reported the problem to Trossen support but haven't heard back as yet.
    I suspect the problem is with the UART for the servos but have no idea how I can test that. I've ordered a new Arbotix board so I can eliminate that as an issue but find it hard to believe the board has such an intermittent problem.
    Any suggestions on how I can diagnose the problem would be appreciated.

  2. #2

    Re: Hexapod Randomly Freezes

    Sounds like either an electrical glitch/short on the TTL UART bus, or a problem with the UART bus driver chip.

    Do you have a logic analyzer and scope on the UART bus? What do they show?

  3. #3

    Re: Hexapod Randomly Freezes

    Again Hard to say...

    I am guessing that maybe more than one servo reset itself to have ID #1, which confuses things... Or maybe one of the servo wires has a short in it. Sometimes it can be intermittent as maybe wire caught in joint and only in certain positions does it actually short...

    Without scope or the like, I would probably start off, by unplugging all but one leg and then try the AX test and see if it sees any servos.
    Hopefully yes and hopefully the right ones for the leg.

    If it fails to see servos on that leg, try a different one... Or try removing connection from Coxa, to femur (Horizontal Hip to Vertical Hip) and see if it can at least talk to one servo.

  4. Re: Hexapod Randomly Freezes

    Thanks for the advice. I'm now inclined to think it may be a short in one of the wires as moving the robot does seem to bring the problem on. it seems to be associated with one leg. I've got some spare cables on order so will replace the ones on that leg. I'm also sick of being in the dark so have ordered a Saleae Logic 8. Hopefully that will help too.

  5. #5

    Re: Hexapod Randomly Freezes

    Often you can inspect the wires and see if there looks like a cut or crimp in them. I had a few that went bad, due to me not being careful on how the wires were run. The worst one was one that I did not give enough slack to, and wire broke internal. Sometimes it made contact and other times not... So having some extra wires around is always a good idea.

    Great choice on purchasing the Saleae Logic 8. As you can probably tell I like the Saleae analyzers (I have three of them), I actually had 4, I had the original one, which I gave away, then the earlier 16, then the 8 and also now the Pro 8.

  6. Re: Hexapod Randomly Freezes

    Yes I had a close look at the wires but can't see any damage so I'm hoping it is an intermittent internal break. When my new cables arrive I'll replace the suspect ones and see how that goes. It may be something else in which case the Saleae should help. I'm glad you like them. They seemed pretty solid and I was swayed by the 50% enthusiast discount. And having analogue inputs as well as the digital is a big improvement on the previous model.

  7. Re: Hexapod Randomly Freezes

    Good news. I replaced several cables but the main culprit was one with a couple of nicks in the insulation. I'm pretty certain it was shorting out on the frame. Anyway, after replacing that one and a couple others it's performing well. I think though that some of the original cables are a bit short and too tight so I'll be replacing them to avoid a repeat. Thanks for putting me on the right track. There are so many things that can go wrong it's easy to miss something.

  8. #8

    Re: Hexapod Randomly Freezes

    I am glad you have it working!

    Yes many times it is the simple things that you don't check for, that get you.

    Example: I have been playing around with the OpenCM base code to try to improve some things. Like allow Serial communications to happen without holding up everything. But then when I was testing on one board the servos were not moving... After debugging lots of things, I found that all three servos XL430-W250-T don't work. It became more obvious yesterday, when I plugged any of the three in on the 485 expansion board (They are ttl...), the RX led remained on... Tried firmware recovery, which does not see any of these...

    So now to ship them back to Robotis, to probably have their communication chips replaced.... Not sure what I did, but maybe short to put 12v on DXL line?

    So yep the simple things

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 13
    Last Post: 06-21-2016, 11:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts