Results 1 to 3 of 3

Thread: Arbotix and RoboPlus

  1. Arbotix and RoboPlus


    I've just got the Arbotix controller purchased from Trossen. I've spent some time trying to configure AX motors, but in vain.
    I got RoboPlus program and followed up these steps:

    (1) I've installed software RoboPlus;
    (2) I've installed FTDI driver (I've checked for update on Win10 and there is none);
    (3) I've plugged in voltage source (it's around 10.5V, the servo blinks red when connecting it to Arbotix which means it gets the voltage);
    (4) I've plugged the FTDI cable, green wire facing green sign and black wire facing the black sign on the Arbotix board;
    (5) I've connected AX12A;
    (6) Jumper is placed on Vin and Middle pin.

    You can see it in the image attachment.

    What I've done next is:

    (1) I've opened RoboPlus 1.1.3 version;
    (2) I've opened expert mode and entered into Dynamixel Wizard;
    (3) I've got the port COM11 (confirmed via Device Manager that it is FTDI cable) which I've opened and I've tried basic search which ends up with nothing, shown in attachment as well;
    (4) Then I've tried checking the firmware (I have no clue why should I meddle with it, just something I've checked via google);
    (5) What happened is what I'm also going to attach in the attachment section. Upon hitting search, everything grays out and I can't use any other option. I've waited some time for something to happen but it wasn't working. When hitting the search the USER LED blinked a few times and it was radio silence after that. Unplugging AX12A, like suggested, and plugging it back in, didn't show any results whatsoever.

    Do you have any clue what is happening and what should I do?

    The only equipment I have is:

    (1) The aforementioned supply of 10.5V and 3.5A, which by looking at specs of AX should be enough (I've even tried on two laptops and with an Arduino plug of 9V and 1A, all the same results);
    (2) Arbotix-M Controller REV-B from Trossen;
    (3) AX12A motors;
    (4) FTDI cable.

    I've seen people working with some other equipment, but I cannot obtain them now and time is sensitive to me.

    EDIT: I've noticed that firmware requires USB2Dynamixel. Is there any way to avoid that?
    Click image for larger version. 

Name:	edit_01.png 
Views:	472 
Size:	19.8 KB 
ID:	7451
    I've added one more image to this post. I've desperately tried to use 'search all'. After an hour of search it turned up with no results. I've even took a step forward to check in Device Manager is the UART configured as to match AX12A communication protocol. I've checked the wires. They conduct (from 9V voltage): 9.39V from GND to Vcc, 4.42V from Vcc to Data and 4.9V between Data and GND.

    I've even tried using any of the 12 AX12A I've got, from two different suppliers, but there is no difference. Am I missing some drivers?

    Edit 2: What I've realised is, when I enter RoboPlus Manager, but not Dynamixel Wizard, and use option AutoSearch, my USER LED starts blinking and after some time I receive the following message:
    Click image for larger version. 

Name:	edit_02.png 
Views:	455 
Size:	82.2 KB 
ID:	7452
    Is there any connection with me not being able to find servo and me not being able to use auto search? Why is LED blinking? It's getting confusing.
    Connecting to COM11 by pressing 'Connect' button produces the same error. But pressing that button in Dynamixel Wizard does not and it enters without any problem. I also cannot do anything with Controller Firmware. After message that I need to plug off and in the power to Arbotix, it grays out and nothing...

    Can you help me, please?
    What I'm doing wrong?

    Thanks in advance!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	03.png 
Views:	446 
Size:	52.2 KB 
ID:	7450   Click image for larger version. 

Name:	02.png 
Views:	477 
Size:	53.7 KB 
ID:	7449   Click image for larger version. 

Name:	01.png 
Views:	463 
Size:	22.8 KB 
ID:	7448   Click image for larger version. 

Name:	51421339_2178057089121439_2381024689448288256_n.jpg 
Views:	512 
Size:	56.8 KB 
ID:	7447  
    Last edited by MayorKanabe; 02-08-2019 at 10:47 PM.

  2. #2
    Join Date
    Sep 2010
    Rep Power

    Re: Arbotix and RoboPlus

    The arbotix is not immediately compatible with any part of RoboPlus.

    The Xbee/FTDI UART of the arbotix does not talk directly to the dynamixel buss, so you have to program the arbotix to act as a pass-through device to be compatible with the Dynamixel Wizard component of RoboPlus (have all data received from FTDI Serial object transmitted out through the Dxl Serial object, and vice-versa).
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    gives free advice only on public threads

  3. Re: Arbotix and RoboPlus


    Thanks for the answer!

    Can you explain me how to do that?

    EDIT: I've realised that I can upload ROS sketch to Arbotix and that allows me to communicate via DynaManager.
    Since I'd like to set up all registers in RoboPlus, which sketch should I upload?
    Can you direct me a bit?

    Last edited by MayorKanabe; 02-09-2019 at 12:39 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Roboplus Task help!
    By Aubby in forum Rovers
    Replies: 0
    Last Post: 08-02-2016, 01:51 PM
  2. Replies: 7
    Last Post: 01-19-2015, 04:41 AM
  3. News/Announcement PSA: USB2AX and RoboPlus 1.1 problems
    By Xevel in forum Arbotix, Microcontrollers, Arduino
    Replies: 3
    Last Post: 01-20-2014, 04:51 PM
  4. Bioloid RoboPlus Motion Editor
    By herman2992 in forum Humanoids, Walkers & Crawlers
    Replies: 4
    Last Post: 01-14-2011, 08:16 AM
  5. Question(s) Using CM-5 with Roboplus Task
    By jarred in forum Software and Programming
    Replies: 4
    Last Post: 04-30-2010, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts