Results 1 to 6 of 6

Thread: Dynamixel MX-28 no longer turning

  1. Dynamixel MX-28 no longer turning


    So I have the weirdest situation and I don't know what to make of it. I have a chain of 3 MX-28 and at the end one AX-12 (one of the arms in my robot). They are controller by an SMPS2dynamixel / USB2AX. This all worked well for a while, but then one day I was working on it and everything was fine, the next day the whole thing wouldn't start at all. I managed to identify the problem at the first MX-28 in the chain, which doesn't turn, is not recognized in the dynamixel manager / r+, but the other motors are sometimes visible. They appear quite randomly in DM, except for the AX-12, which always shows up, although it's the last in the chain. So my faulty motor does pass the data all the way down the chain, but it itself is completely invisible. I also attempted to connect the chain in the reverse direction, same results. If I connect the other motors individually, they work.

    I also had a spare MX-28 from a set, that I never touched. So the first thing was to use that one in place. But it also didn't work from the start. Could it be that one of these motors simply doesn't work from day one? Are they that fragile? I never dropped anything.

    I tried to do a firmware update, using both v1 and v2 of the Robotis software, but it doesn't work. On that step "turn the dynamixel on and off", after I do, the software doesn't see the motors.

    So, does anyone have any helpful suggestions? I'm at a loss..

  2. #2

    Re: Dynamixel MX-28 no longer turning

    I would probably recommend posting up on Robotis Forum: It may turn out your servo is damaged and you need to do an RMA...

    My normal suggestions would be to use the Robotis software to do firmware recovery/update: Since you have an AX-12 I am guessing
    probably should be protocol 1...

    Also USB2AX - Might need to update the firmware to latest versions to support protocol 2?
    Might look up at

    Again if you re updating the firmware to protocol1/2... You might try Robotis beta software:

    Now if you do recover Firmware, The servos will be configured back to their original default configuration, which for MX-28 I believe that has a baud rate of 57600 whereas AX-12 have 1000000. In both cases ID will be set to 1...

    As the instructions for firmware recovery mention, you should only have one servo plugged in... And after you you recover firmware, you may have to reconfigure the software to 57600, then do search, hopefully it finds your servo, at which point you can set your ID and other things. If you set the baud to something else, you will then again have to reset the software baud rate to your new value and again search for your servo...

    Good luck.

  3. #3
    Join Date
    Sep 2010
    Rep Power

    Re: Dynamixel MX-28 no longer turning

    Has the cable assembly to the first servo in the leg been damaged? If you plug the power/comm cable assembly into the spare connector on the other end of the leg, do any of the servos appear?
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    gives free advice only on public threads

  4. Re: Dynamixel MX-28 no longer turning

    I did mention that I already tried to do a firmware update, using the Robotis software, tried with both versions for dxl v1 and v2, and scanned for multiple baud rates, especially 57600, which according to the manual is the default speed after update. And of course I only connected one motor at a time for the update, the software warns you multiple times of that.

    I also tried with different cables and with both connectors on the motors in question, nothing is visibly damaged.

    Playing around with various possibilities, I updated the firmware for all three MX motors, so they are reset at 57600. I managed to get the dynamixel manager to see the faulty one once (just once!) and it worked and moved, so I tried to quickly update the firmware on it too, but that failed. What I now see in the dynamixel manager looks this:

    Click image for larger version. 

Name:	Untitled.png 
Views:	220 
Size:	20.5 KB 
ID:	7487

    So when I connect the problem motor, it does make another entry in the result tree, but fails to acknowledge it as MX-28 and I can't access any of its properties. If I search on anything other than 57600, I get no results, as expected.

  5. #5

    Re: Dynamixel MX-28 no longer turning

    Maybe something is damaged in the servo. I had something go wrong with an OpenCM9 (or was it the OpenCR board) which have both been repaired, which I think caused a spike on the DXL buss and it damaged the communication chip in a couple of servos...

    I did the RMA and Robotis repaired all of them...

    Again I would ask up on Robotis site, @willson may have a few suggestions and maybe direct you to the Repair center and to do an RMA process.

  6. Re: Dynamixel MX-28 no longer turning

    Just to follow up on this, for people who end up on this thread, I talked to the guy on the Robotis forum and after a lot of experimentation he also gave up and told me to do this RMA process.

    Thanks for your help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Dynamixel AX-12A won't actuate if the chain is longer than 6
    By zhanginou in forum DYNAMIXEL & Robot Actuators
    Replies: 12
    Last Post: 12-13-2017, 10:15 PM
  2. Turning a backhoe into a robotic arm
    By pengyou in forum Robotics General Discussion
    Replies: 6
    Last Post: 11-30-2014, 05:31 AM
  3. Question(s) Arbotix-M no longer accepts FTDI communication, USER LED always on
    By NSz in forum Arbotix, Microcontrollers, Arduino
    Replies: 2
    Last Post: 10-29-2014, 12:16 PM
  4. Question(s) Iv'e got a question about quad tracks and turning
    By ntopper in forum Rovers
    Replies: 6
    Last Post: 08-19-2013, 01:52 PM
  5. Question(s) arbotix digital pins and board turning on and off
    By [email protected] in forum Software and Programming
    Replies: 4
    Last Post: 06-24-2010, 12:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts