Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: PhatomX with XL430-W250 servos

  1. #21

    Re: PhatomX with XL430-W250 servos

    The OpenCM9.04 has a USB port, so you could just use a short USB cable to talk to it using serial port.
    However, the serial USB implementation of that board has always been a bit finicky for me -- send too much at once, and the firmware locks up.
    To use the serial port on the Pi 3, you may have to do some hacking of the boot config file on the Pi, because by default the "good" serial port is used for the Bluetooth and the "limited" serial port has issues (slow, not buffered, I forget what else.) In fact, I don't even remember if the serial pins are enabled at all on the Pi 3 by default. (They may be, just configured for the "bad" port.)

  2. #22

    Re: PhatomX with XL430-W250 servos

    @jwatte - I have not played as much with host talking quickly with large amounts of data through the OpenCM board.

    I have tried to fix some of the latency issues of the OpenCM board talking back to the PC...

    For a long time, the hard coded 3ms timeout was always used on the OpenCM board to force the USB to send back to host, which I saw, so worked with Robotis to add Serial.flush() support, and to add calling it to DynamixelSDK... But the flush() is still not as optimal as it could be, it just zeroed out the ms timeout counter so the next ms timer would do it then.

    As you mentioned, the Serial port on RPI3's expansion connector is a bit flaky and I normally swapped them... There are several links on the net about this including:

    I also forgot to mention, that in some of the Phoenix/PhantomX code bases I have a version of the Input code that does not talk through XBess. There was a simple handshake between the two.

  3. Re: PhatomX with XL430-W250 servos

    Thanks guys for the help. I got it working ok using a simple cross connect of Rx and Tx over the serial ports
    RPI3 Tx on GPIO14 (Pin 8) to OpenCM9.04 Rx on A5
    RPI3 Rx on GPIO15 (Pin 10) to OpenCM9.04 Tx on A4
    The initial problem I had was due to not having a common ground (thanks for reminding me Kurt).
    Initially I used the ttyS0 Serial port to prove it worked ok. After that I swapped the serial ports to use the high performance ttyAMA0
    I commented out the XBee configuration code as well.
    I'm using wifi to connect to the RPI3 from my PC over VNC so don't need a high performance bluetooth interface.
    I'm now able to simulate the Commander buttons and joystick using Python code so the next step will be to connect the Lidar and the Pixy2 to the RPI3.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XL430-W250 Stop moving randomly
    By Larcay in forum Software and Programming
    Replies: 6
    Last Post: 02-15-2019, 03:03 PM
  2. New XL430-W250-T DOES NOT MOVE
    By Larcay in forum DYNAMIXEL & Robot Actuators
    Replies: 5
    Last Post: 09-14-2018, 11:54 AM
  3. News/Announcement Beta testing XL430
    By Zenta in forum DYNAMIXEL & Robot Actuators
    Replies: 6
    Last Post: 04-22-2017, 11:55 AM
  4. Replies: 4
    Last Post: 12-09-2014, 09:01 AM
  5. HITEC Servos: Can the OEM RN-1 Servos handle 7.4V?
    By MYKL in forum DYNAMIXEL & Robot Actuators
    Replies: 10
    Last Post: 06-23-2008, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts