Results 1 to 3 of 3

Thread: Can't connect the servo after input voltage error

  1. Can't connect the servo after input voltage error

    Hello,

    The Dynamixel Wizard can't find my AX-12A and MX-64 servos after input voltage error. It was too high. Now I using a proper adapter.
    I have tried the reset example in Dynamixel SDK but not work, it said "[ID:001] Try factoryreset : Aborted"
    Also the read_write exapmle said "[TxRxResult] There is no status packet!"
    Is there a way to fix it?

    Liang

  2. #2

    Re: Can't connect the servo after input voltage error

    I am/was going to suggest asking up on Robotis forum, looks like someone asked similar one:
    http://en.robotis.com/service/forum_...stx=&stx=&sfl=
    Except they mention AX-12w...

    Might help to know additional information, like how how are you connecting servo up to PC? What OS? What version?
    What voltage level were you using and are now using?

    Does the LED in the servo blink when you apply power to the servo?

    If you are using something like USB2Dynamixel or U2D2 or in some cases OpenCM9.04... (And I believe USB2AX)

    I would suggest using something like the Dynamixel Wizard app, and try to do a recover firmware on the servos. Often times, when I do this, I don't plug in the servo until it is trying to find it and/or unplug/replug in the servo... Only one servo connected. Assuming you can do a recovery, the servo will have ID #1, at the default Baud rate for the specific servo. 1000000 for AX-12A, don't remember MX64 as I have not owned any... But I think it is 57600...

  3. #3

    Re: Can't connect the servo after input voltage error

    If you hooked too high voltage to the servos, chances are that the electronics are fried.
    Robotis can replace the PCB of the servos, and doing so for the MX-64 servos will be much cheaper than buying new servos.
    Doing so for AX-12 servos may be more than half the replacement cost, though -- ask them for an estimate before you send them in.
    There is some chance the DXL bus of the USB2Dynamixel fried instead, and replacing just the adapter might make you able to communicate again. You could use an oscilloscope or logic analyzer to figure out whether the signals are going out or not.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. IMAX B6 Charger "INPUT VOL ERROR"
    By TXBDan in forum Power
    Replies: 10
    Last Post: 06-04-2013, 11:15 AM
  2. Question(s) Arbotix Robocontroller w/Bioloid - voltage regulator very hot with 12V input
    By ncostes in forum Arbotix, Microcontrollers, Arduino
    Replies: 11
    Last Post: 04-11-2013, 08:55 PM
  3. Question(s) Compiling Error with Arduin IDE / Pypose : could not read servo error
    By lweydert in forum Software and Programming
    Replies: 3
    Last Post: 03-27-2013, 08:16 AM
  4. Choosing input type for home made servo controller
    By tigrlily in forum Arbotix, Microcontrollers, Arduino
    Replies: 0
    Last Post: 06-05-2011, 03:23 PM
  5. Question(s) Phidgets and servo voltage
    By Eric in forum Arbotix, Microcontrollers, Arduino
    Replies: 5
    Last Post: 05-12-2008, 08:32 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •