Results 1 to 5 of 5

Thread: MX-64 bricked after update

  1. #1

    MX-64 bricked after update

    So, I have this problem where I have some MX-64 servos running firmware version 33 (pretty old.)
    I've tried updating them with Dynamixel Wizard 1.0, but that update reports "failure" and then the servos are bricked.
    (They "worked fine" being controlled before the attempted update.)

    Robotis support engineers claim that this means the servos have a "damaged I/O chip" which makes them fail to handshake in the update, yet they somehow work fine in normal operation.

    I'm ... a little skeptical. I can't really think of how such damage could happen. Does anyone have a good idea about what that particular damage would be? Something that would damage the TTL interface chip (74-125 style buffer) such that it would work fine for megabit-speed and 57 kbps speed control, but not for bootloader/updating?

  2. #2
    Join Date
    Sep 2010
    Location
    ಠ_ಠ
    Posts
    2,285
    Images
    27
    Rep Power
    275

    Re: MX-64 bricked after update

    So they are 'bricked' in the sense that they cannot be upgraded, but work fine otherwise? That sounds entirely like a bootloader software issue. I know some persistent parameters were moved around in memory (e.g. offset/calibration parameters) between certain versions of the firmware, so maybe something got copied to a location where it should not have (like on top of the bootloader).
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    bleh

  3. #3

    Re: MX-64 bricked after update

    No, they are "bricked" as in they don't work at all (although they blink when powered on.)

    Specifically, this is the chain of events (reproduced on two servos):

    1) Servo communicates fine at 1 Mbps
    2) Servo can be scanned in Dynamixel Wizard 1.0
    3) Dynamixel Wizard suggests the firmware is too old, and proposes an upgrade
    4) I accept the upgrade, click through the dialogs, and power cycle the servo to bootloade it
    5) The upgrader sits there for a while, the progress bar moves forward, and then the upgrader says "upgrade failed"
    6) At this point, the servo blinks when powered on, but cannot be scanned on the bus, nor seen with the bootloader upgrade in Dynamixel Wizard 1.0
    7) I tried one of these servos in Dynamixel Wizard 2.0 beta. It could apparently actually see the servo, and I initiated another bootloader upgrade.
    8) This second bootloader upgrade also failed, and this servo doesn't even blink when powered on now.

    Robotis is adamant that this is a damaged I/O chip, although they claim version 33 software (on these servos) is so old they can't test with that themselves. My suspicion is there's an incompability between the current Dynamixel Wizard, and servos running firmware 33, but I have very little clout in this negotiation ...

    I've asked them for a description of what, actually, the failure is, that results in these symptoms, so that I can make sure I prevent that kind of failure in future designs.

  4. #4

    Re: MX-64 bricked after update

    Yikes!

    I don't have any MX servos so not much help...

    I am sure you tried all of the tricks of trying to get it to reprogram. Like only plug it in, when it the Dynamixel Manager is ready to program the chip.

    Are you using one of their official U2D2 or USB2Dynamixel adapters? I remember seeing someone on Robotis forum trying to update and failing using UsB2AX and they said they could not say and suggested using one of their own adapters...

    If it were me, I would probably waste more time and try using R+ Manager 2 (light). And try configuring it to try to talk through OpenCM board. First configure as product Robois Mini. Then do a firmware recovery on an OpenCM9 board, then configure to update and test... Probably needing to configure the right ports and bauds.

    Then click the home button, and choose the Dynamixel as Product. And then try to do a firmware recovery on one of the servos... Would probably put on Protocol2 version... But if that by very slight chance works, you could then probably downgrade it again back to a protocol version of the firmware...


    Almost sounds like it erased everything?

    Good luck

  5. #5

    Re: MX-64 bricked after update

    Yes, I'm using a USB2Dynamixel.

    Yes, when the bootloader somehow failed, it ended up with a partial program, which presumably ends up crashing right after boot.

    I'll probably pay the fee and send them in for RMA, though ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Update firmware CM-510
    By chitti in forum Software and Programming
    Replies: 0
    Last Post: 01-16-2013, 05:42 AM
  2. Bricked XBEE's
    By Quantum in forum Software and Programming
    Replies: 1
    Last Post: 10-17-2011, 12:54 PM
  3. Any update on the new bioloid kit?
    By praelian in forum Humanoids, Walkers & Crawlers
    Replies: 6
    Last Post: 09-14-2009, 11:40 PM
  4. Bricked XBee [Sigh]
    By Adrenalynn in forum Arbotix, Microcontrollers, Arduino
    Replies: 25
    Last Post: 06-15-2009, 11:49 AM
  5. Speecys SPC-101 First Update
    By cdraptor in forum Humanoids, Walkers & Crawlers
    Replies: 6
    Last Post: 09-18-2007, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •