Results 1 to 5 of 5

Thread: Using Dynamixel AX-12 A

  1. Using Dynamixel AX-12 A

    Now in the university where i work i am using an smart arm robot with 7 dynamixel AX-12A.
    the arms stopped working i think because the amr is working in a experiment with water and got wet and a bit of corrosion in two servos and some cables.

    -I changed two cables and two of the AX-12 A, and now I have few problems.

    -The Servos when not working can't hold the arm because they are too losse (I don't know why), but the older ones they were not like this so i suspect this ones are actually faulty and someone that worked in the arm before left them aside).

    When trying to use the software Roboplus with some little programs that were done already by someone, the robot does not move as the programs says, it just make some rough movements then it stops, but these two actuators that I changed make noise like its trying to move the arm.

    -also the two actuator that I replaced now are showing a red led blinking (it suppose to be that they might be overloaded apparently).

    I have one question, If I install new actuators, do I need to configure them before start the program that I have done before?, set like a starting position, or something like that

    I would appreciate if you also could recommend me a manual or tutorial of how to use this AX-12 with a CM-530.

    Thank you.

  2. #2

    Re: Using Dynamixel AX-12 A

    Yes, you need to configure their ID so they match the ID of the current servos in the arm.

    Btw: You should be able to use Dynamixel Wizard and hook up just one servo at a time. Scan the bus to find the servo, then turn on torque on the servo (important!) and command it to go to different positions, and see if the horn moves appropriately or not. You can identify which servos are "good" versus "bad" like that, and also make sure that all the servos have the correct ID for their position. One by one: the best way to troubleshoot!

  3. Re: Using Dynamixel AX-12 A

    Thank you jwatte for helping me with my problem.
    I tried as you told me and now the arm robot is working.
    So what I need is the arm to make a cycle of movements, the servos are working and makes the movements as I need.
    Still I have a problem now, the arm moves well when I select the motion to play; but after few times like 10 times the motion is ,moving the position of the arm goes down, the arm falls and stays there and does not reach the position that I set up in the software.

    I am wondering what is the problem as everything is apparently working, is just after few cycles or playing the motion this problem shows up.

    I guess is something to do with the servos 2 and 3 that are the ones that ,makes this movements and in one point it fails.
    Does someone have an idea what could be? Maybe any kind od set up or configuration I am missing?

    Thank you.

  4. #4

    Re: Using Dynamixel AX-12 A

    After the servos fail, can you move them by manually moving the arm? Does the red LED blink?
    It's quite possible the servos detect overheating and shut down.
    You should be able to read back the status from the servos, and see if any of the status error bits are set.

  5. #5

    Re: Using Dynamixel AX-12 A

    As @jwatte mentioned, it could be that the servos are overheating and shutting off.

    If you let the setup rest for a hour or so, does it work again?

    If it still fails and or works a bit and then not or .... then I would again suggest to do some additional debugging.

    Things like:
    a) Make sure all of the servos still have their correct servo ID. Sometimes there is some condition that causes a servo to reset back to ID #1... It happened often enough to me (and others) with the PhantomX hexapod, that I avoided having any servo with id #1 (renumbered #1 to be #19 in this case). Then my initialization code would ping all of the servos and if it found that one of the servos did not respond (only one) and servo #1 then existed, the code would renumber #1 back to the the servo ID that was missing...

    b) Check wiring again: For example is one of the servo wires in a place that can be pinched by the brackets and or is not enough room for it to properly move? Sometimes this can result in shorts and or breaks, where if you then manually move the servos it suddenly works again.

    c) You did not mention if wall wart or battery? If battery make sure the battery is not drained...

    d) Not likely as it worked at first, but make sure the servo horns are properly aligned. That is you screwed in the horn to the brackets with the correct orientation. This would normally hit on your first attempt to use the servo...

    Good luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Dynamixel AX-12a detected as UNKNOWN in Dynamixel Wizard
    By drfastolfe in forum DYNAMIXEL & Robot Actuators
    Replies: 3
    Last Post: 02-25-2019, 12:30 PM
  2. Replies: 7
    Last Post: 01-10-2016, 03:14 AM
  3. Arduino Library for Dynamixel XL-320 (and Dynamixel PRO if modified).
    By LuisGIII in forum DYNAMIXEL & Robot Actuators
    Replies: 3
    Last Post: 06-07-2015, 11:00 PM
  4. 18 Dynamixel Ax-12A with ArbotiX/Arduino - How to connect the dynamixel?
    By Snuuq in forum Arbotix, Microcontrollers, Arduino
    Replies: 20
    Last Post: 02-14-2014, 11:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts