Hi all,

Hope you are doing well. So, the thing is I use four Dynamixel motors of type MX-28T, each pair used to control a robotic arm , one of the robotic arms is shown in the attached image "Robotic arm set-up".

I use USB2dynamixel (COM19) on TTL mode and actually the motors work words are written to them but read doesn't work for all of them, with the set IDs (each has a unique ID). Attached picture of USB2Dynamixel is attached.

When i tried to check them on dynamixel wizard, I connect only one motor at a time when I search for the dynamixels, I only found that one of the 4 is recognized and others when connected separately aren't, as shown in "Dynamixel Wizard " attched picture. The LEDs of all 4motors blink normally when power cable is plugged.

I tried to update the firmware or even do recovery but still the wizard can't find the motors in the first place. So, does anyone know how I can get the other 3 dynamixels to be recognized on the wizard or what actually might be causing this problem and why words can't be read on Labview, although it write words!?

Thank you so much in advance. your help would be appreciated.

Some info. :
-Used controller and program: Myrio, Labview 2016
-OS: Windows 7
-Protocol used for dynamixels in Labview: protocol 01
- Each two dynamixel motors are connected in series

Attached images: shorturl.at/imDM7