Results 1 to 2 of 2

Thread: Xbee Communication Problems with Phoenix Code for Hexapod Robots

  1. Xbee Communication Problems with Phoenix Code for Hexapod Robots

    Hello, I've been trying to prepare a few of the PhantomX Mark II Hexapods with the Phoenix code for a micro-controllers class but I've been having issues with communication between the x-bees, specifically the one on the Arbotix board.

    When the code loaded on to both the commander and the robot, they will connect and the robot will move for about 30 secs to 1 minute then the communication will drop. I suspect the issues are with the arbotix xbee because the controller continues to output the commands in the serial window even after communication is gone.

    Some trouble shooting I've done is reorganizing the libraries, using different xbees (with the advanced configurations), using different boards, using different robots and using the virtual controller instead of the handheld. I even tried to place a few capacitors on the power distribution board because I thought that maybe the arbotix board was being overloaded causing the xbee to reset but this didn't really make a difference and if anything I think it made the problem worse.

    I'm not really sure what to try next and I would really appreciate any help or advice anyone could give me. Thank you.

  2. #2
    Join Date
    Jun 2011
    Location
    USA
    Posts
    547
    Images
    107
    Rep Power
    42

    Re: Xbee Communication Problems with Phoenix Code for Hexapod Robots

    Quick question for helpful context: which Xbees are you using?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Problem phoenix code for my hexapod
    By Demoniac in forum Projects For Request and/or Sale
    Replies: 2
    Last Post: 10-05-2018, 06:11 AM
  2. Communication between two arduino boards via Xbee
    By Thalvus in forum Software and Programming
    Replies: 8
    Last Post: 05-20-2016, 09:04 PM
  3. KURT< HELP!!!!!!!!! Phantom X Phoenix code to run on my hexapod.
    By gregorio_626 in forum Projects For Request and/or Sale
    Replies: 8
    Last Post: 01-26-2016, 05:51 PM
  4. Question(s) Robust communication between Python and Xbee?
    By ddugi79 in forum Arbotix, Microcontrollers, Arduino
    Replies: 11
    Last Post: 02-11-2015, 07:22 PM
  5. PhantomX Hexapod MK-II Phoenix Code Getting Started Guide
    By kgranat in forum Humanoids, Walkers & Crawlers
    Replies: 6
    Last Post: 03-11-2014, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •