Results 1 to 5 of 5

Thread: Arduino 1.8.10 ?

  1. Thumbs up Arduino 1.8.10 ?


    I have just bought the Phantom X Reactor and I'm trying to test it with Arduino.

    I followed the following process : I did'nt find a guide for arduino 1.8.X.

    Then the compilation doesn't work. I added the 2 folders Hardware and Libraries in the Document/arduino. I can see my board : ArbotiX Std. I choose my Serial port but when I compile a code like librarytest etc, I have the following mesage :
    Arduino : 1.8.10 (Windows 10), Carte : "ArbotiX Std"
    loading hardware from D:\Programs\Arduino\hardware: loading package arduino: loading platform release: Error reading file (D:\Programs\Arduino\hardware\arduino\avr\boards.txt:0): Invalid line format, should be 'key=value'
    Erreur de compilation pour la carte ArbotiX Std
    Did someone experience this error ? Doest I have to install the arduino 1.6 but It will be incompatible with my other projects ?

    Last edited by smart.stadium; 11-21-2019 at 04:11 AM.

  2. #2
    Join Date
    Sep 2010
    Rep Power

    Re: Arduino 1.8.10 ?

    The board manager definitions from this thread will probably still work...

    I do not have any arbotix boards to test, but I do not really expect anything to have broken since earlier 1.8 versions.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    gives free advice only on public threads

  3. Re: Arduino 1.8.10 ?

    I followed your process and that's didn't work (same error).
    I removed all changes when I followed the 1.6 guide. That's didn't work (same error).
    I deinstalled/reinstalled Arduino 1.8.10. I followed your process (add board in file/Preferences menu - version 0.0.3) and I added the libraries (1.6) in my folder "...documents/Arduino". I didn't paste the folder Hardware just Librairies and now...That compiles.

    Very many thank @tician
    Last edited by smart.stadium; 11-21-2019 at 03:21 AM.

  4. #4

    Re: Arduino 1.8.10 ?

    Like @tician, I have not tried it in awhile, but it worked the last time I did it.

    Some things to look out for. I am assuming that you did not install it using Windows apps install, but instead downloaded it from Arduino? I always do the later... I also always download the zip file and I keep different versions in different directories.

    Check for conflicting versions, of Arbotix stuff stashed in different areas...
    That is, there are three places that things like this can be installed.

    a) Where you installed your Arduino: so if Arduino is installed at: D:\programs\Arduino , then it would be sort of at the directory you mentioned. Typically I don't think the Arbotix stuff has been installed in that hardware folder.

    b) Where your sketches are stored: Like my user directory is c:\Users\kurte so Arbotix stuff might be installed at:
    This is actually where mine is stored, as I am using my own version that pre-dates the Trossen Beta and Tician's wrapping it up in a better way.

    c) Where the Board manager typically installs stuff. In your Arduino15 folder, which on my machine is at:
    On my machine this is where the installs are for things like Adafruit, OpenCM904, OpenCR...
    And where I expect that using Tician's install puts the stuff.

    So again you probably need to check out your system in all of those places maybe remove them and install fresh...

  5. Re: Arduino 1.8.10 ?

    My issue is solved. The Tician's json works fine. But my Arduino software was broken after a lot changes. After reinstalling it and adding the json, all is OK. I can compile ROS program to set the ID in the servos.

    But at the moment DynaManager Software doesn't work but It' just a question of time...I hope.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Arduino to Arduino serial servo control
    By cpunk7 in forum Software and Programming
    Replies: 1
    Last Post: 06-30-2015, 01:30 PM
  2. Question(s) Arduino- xbee -xbee-arduino - stepper motors
    By Icemonkey in forum Arbotix, Microcontrollers, Arduino
    Replies: 7
    Last Post: 06-04-2012, 12:35 PM
  3. PVision library for Arduino (Pixart/Wiimote to Arduino)
    By shobley in forum Robot Computers
    Replies: 1
    Last Post: 03-01-2009, 05:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts