Hi, all. I am new to the forum, but appreciate the value in helping each other. I have some coding and electronics knowledge, and some Arduino knowledge, but no experience with the Trossen / Arbotix / Dynamixel platform. I am on Win 10, although I have other platforms around.

I just purchased the PhantomX Robot Turret kit and am working though the setup outlined at:

I got past steps 5 and 6 ("Blink" and "Control a DYNAMIXEL Servo").

The first time through, I overlooked the next link under "Next: Set DYNAMIXEL IDs" at the bottom of the page, and instead I went back to the previous page.

On the PhantomX Turret page, there is a different section where I left off entitled "Setting Your DYNAMIXEL IDs", which leads me to this page about setting up Dynamanager:

I uploaded the ROS.ino sketch to the Arbotix-M, and then downloaded and ran the .BAT in the parent folder of dynaManager13_win_64_java. I interpret this to be a compiled version of DynaManager. The UI loads, but as soon as I send a command, the program crashes and an error dump occurs:

# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000007110b5db, pid=11780, tid=0x00000000000004cc
# JRE version: Java(TM) SE Runtime Environment (8.0_261-b12) (build 1.8.0_261-b12)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.261-b12 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C [jSSC-2.8.dll+0xb5db]
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

The page that outlines Using Dynamanager suggests that there may be instances when a user needs to "run the program from within the Processing IDE". So, I thought I should try running the code within Processing. I downloaded and installed Processing, and I placed the ControlP5 library where recommended. Then, in Processing, I selected File > Open > dynaManager.pde and selected Run. I see the same error mentioned, " The function "valueLabel()" does not exist" at lines 188 and 228. I also see "The class "ListBoxItem" does not exist" at line 360 and "The value of the local variable "curServoid" is not used" at line 384.

As I was writing this, I figured out that there was a link at the bottom of the page:

entitled "Next: Set DYNAMIXEL IDs", and this takes me to "Setting DYNAMIXEL AX and MX Series Firmware, ID, and BAUD with ROBOPLUS 1.0". I downloaded and installed ROBOPLUS 1.0, set the COM port to COM21, and tried searching for the one connected Dynamixel, but it did not find the device. I saw a comment somewhere that ROBOPLUS won't work through the Arbotix-M.

In another support thread, I saw a reference to Dynamixel Wizard having been the solution to another user's problems setting IDs, but it also fails to find my Dynamixels when I limit the search to the COM port I know I am using (21) and I have pre-set the baud rate in Device Manager to 57600.

What is the proper tool for setting the Servo IDs under Windows 10? I want to get on to assembling the turret, but I understand it is best to set the ID's before assembly.

So, I am stuck. Any assistance would be appreciated.