Results 1 to 5 of 5

Thread: Strage Problems with usb2dynamixel

  1. Unhappy Strage Problems with usb2dynamixel

    Hello everybody,

    I am new to this board and googled the whole day long to find some answers: no sucsess till now:

    I have some serious prolems with the usb2dynamixel converter: I want to control a robot arm via PC using Windows7 and a usb2dynamixel converter and 13 AX12+ Dynamixels. Everything went fine until yersterday: My first machine is a Windows Vista based 32bit system, where I developed my software and tested the Dynamixel Configurator, so far, so good. Yesterday I tried two different Systems ( Win7 on my Laptop and Server 2008 on a different machine) On both machines I get major connection problems: When I look at the LED (RX) on the usb2dynamixel converter ist is flashing wild and does not stop sending data to the PC: so the whole system gets unstable and I can not connect to the TTL DynNet. On the Vista machine, there is not such behaviour, but since yesterday I have the Problem that from Time to time the Vista machine just reboots without any reason, even just when I plug in the usb2dynamixel converter! Is there anybody who had such problems before? I can change the OS on the Target Machine (where my app has to work in the future), but then there is still the problem of random reboot. I checked the FTDI-Driver and on all machines they are identically (Version, date, source) So why is the Converter constantly sending data on the Win7 and Server2008 machine and not on the Vista-Machine??

    Please help me, thx a lot in advance...

  2. #2

    Re: Strage Problems with usb2dynamixel

    The Rx LED lights when the PC sends data on the port connected to the USB2Dynamixl. Maybe you have something running on the PCs, custom code or another USB device?

    What's a TTL DynNet?

  3. Re: Strage Problems with usb2dynamixel

    Thanks for your answer: TTL is the Bus-System used for the Dynamixels AX12. So the Network behind the Converter is called the Dynamixel Network. You are right about the Rx LED. the PC keeps sending data without any reason and i have no additional usb devices connected. This happens as soon as the Virtual Com Port is opened, but only on Windows7 machines. The same Software on a Vista machine works without a problem (except the random reboot faliure). I just modified the way the usb2dynamixel interface is connected: now using the direkt connection possibility provided by FTDI and not a virtual com-port any more. The result is that there is no improvement.

  4. #4

    Re: Strage Problems with usb2dynamixel

    I thought TTL DynNet was some kind of software you wrote.

    Direct access (D2XX) uses a dll (API) the same method used by the USB2Dynamixel SDK. I guess you wrote your own custom code?

    Try installing a serial port monitor. You might be able to figure out the source of the communications.

    I'm a little confused...and I might be off base here... you say there's no other USB devices running and it only happens when you open the port? So you open the port with your custom software then the problem starts? What opens the port?

    Geez, FTDI chips are in all kinds of devices. I doubt you're the first person to use a FTDI device in Win7 or Vista. You might want to take a serious look at your software.
    Last edited by MikeG; 03-20-2010 at 11:06 PM.

  5. Re: Strage Problems with usb2dynamixel

    Hi MikeG,

    for testing I do not use use my own made software but the DynamixelConfigurator. At least my random reboot problem seems to be solved. Although the manual says that the powerlines on the ttl socket of the usb2dynamixel converter are not connected to anything it seems possible that there can be some kind kind of power flashback that shuts down the computer. So I disconnected the wires, so that there is only the DATA line going to the powersupply and further to the dynamixels. But there is still the problem with the FTDI and Win7. I even have a different converter to communicate with some other boards controlling some step-motors (Nanotec). My serial port monitor shows there the same result: the computer keeps sending data through the usb port as soon as the port is opened. As I told you I tried it on different machines (two with Win7 and one with Server 2008). I think this is very strange, it seems, that the driver for the FTDI-Chips is not working correctly with Win7 and Server 2008 (the other converter I tried was a USB to RS485 based on the same FTDI-Chip like the usb2dynamixel interface). By the way, the power to the dynamixels is supplied by a SMPS2Dynamixel board.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upload problems with Arduino Duemilanove!
    By cross1933 in forum Software and Programming
    Replies: 8
    Last Post: 05-22-2009, 12:37 PM
  2. Question(s) PX5000 problems
    By anandoc in forum Robot Computers
    Replies: 19
    Last Post: 02-01-2009, 06:11 PM
  3. Bioloid Multiple problems
    By Dmonious in forum Humanoids, Walkers & Crawlers
    Replies: 23
    Last Post: 05-21-2008, 11:32 AM
  4. Problems with Probing Robot
    By Bushwhackr in forum Humanoids, Walkers & Crawlers
    Replies: 1
    Last Post: 01-31-2007, 08:35 PM
  5. Problems linking to libphidget21
    By bidi in forum Software and Programming
    Replies: 3
    Last Post: 01-31-2007, 09:11 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts