Results 1 to 7 of 7

Thread: Question on Serializer WL

  1. Question on Serializer WL

    Hi all,

    I'm new to microcontroller programming so this is a newb on the line. I recently purchased a serializer WL microcontroller (with the USB connector to PC). I'm warming up with the little example with the LED lights in the tutorial (http://www.roboticsconnection.com/mu...Guide_v1.1.pdf)

    The problem is, when I input all the code and hit debug, it runs, but I don't see any LEDs blinking on the serializer. I see three built in LEDs on the serializer, and the third one blinks all the time when I hook it up to the laptop so I'm guessing that indicates power. Numbers 1 and 2 are both off despite what I set the blink rate to in my window (am I looking at the right places?)

    A couple points of suspicion are:

    1. I'm not connected to the laptop via a serial port but rather with the USB connector. In the example, the connection is set to "COM2", which would give me a debug error. I set it to COM3 and it could debug but I'm not sure this is the right thing to do. What should I set it to?

    2. Very stupid question, but you wouldn't have to hook up the serializer to a battery when its already connected to the computer...would you?

    3. I'm running this program on Visual C# 2010 Express, and I think there may be some compatibility issues. For instance, in Form1.cs, I modified my code to be

    private void BlinkLEDButton_Click(object sender, EventArgs e)
    {
    if (Led1CheckBox.Checked)
    {
    s_.BlinkLED(LedId.Led1, Convert.ToInt16(BlinkRateTextBox.Text));
    }
    if (Led2CheckBox.Checked)
    {
    s_.BlinkLED(LedId.Led2, Convert.ToInt16(BlinkRateTextBox.Text));
    }
    }

    where Led1 was LED1 and BlinkRateTextBox.Text was BlinkRateTextBox.Text() in the original code intended to be used in Visual C# 2005. The modifications were made because the original code would give me a debugging error.

    I would really appreciate if someone is willing to give the newb some help. Thanks a ton in advance.

  2. #2
    Join Date
    Jul 2008
    Location
    South Sphincter Idaho
    Posts
    613
    Images
    104
    Rep Power
    64

    Re: Question on Serializer WL

    Hi Cloud,
    I have never used a Serializer, but in reading through the User Manual, on page 10 it talks about power. This may be a good place to start.

    "Once power is supplied, you should see the Red Power LED light up, and the two User definable Green LEDs should be twiddling back and forth. Also make sure you have a power supply which can supply at least 1 amp of power out or more, especially if you have many components connected (e.g. sensors, etc.). In fact, if you have components attached, we suggest you use a power supply rated to supply a minimum current output of 1.5A to 2A."

    This doesn't sound like the LED activity you described.

    Good Luck
    Gary
    Team Maggot---Mechs. "Bheka" (retired), "Maggot Mk.3(A)"
    " Keep your stick on the ice ".... Red Green

  3. Re: Question on Serializer WL

    thanks for the reply.

    I read the guide again and it turns out that for V3.0, there is only....one user defined LED??!!

    the guide is somewhat vague on this. in one place it says that there are two green user defined lights, the other it says there is one. But either way, it's not taking my command.

    When my controller is hooked onto the USB, a green light stays on so I assume its the power light. A red light flickers all the time so I'm assuming its the user defined LED. The question is do I still need a battery when the controller is connected to the PC via a USB? Also, can I just use a regular 9V battery off the shelf (duracell?), like one of these (http://www.scrollinondubs.com/wp-con...oltBattery.jpg), or does it have to be something more specific? I'm asking this question because I also tried using the analog sensor example posted by roboticsconnection but the sensor (SHARP IR GP2Y0A02YK ) outputs no reading...

    Also, would I have to do anything to the firmware?

  4. #4
    Join Date
    Jul 2008
    Location
    South Sphincter Idaho
    Posts
    613
    Images
    104
    Rep Power
    64

    Re: Question on Serializer WL

    I'm afraid I'm not much help here. I doubt that you would be very happy using an off the shelf 9 volt battery. They have a notoriously short life span with much of a load on them. But it might last long enough for some testing.

    Sorry I'm not more help, but I have no experience with the Serializer at all.
    Gary
    Team Maggot---Mechs. "Bheka" (retired), "Maggot Mk.3(A)"
    " Keep your stick on the ice ".... Red Green

  5. #5
    Join Date
    Sep 2006
    Location
    Carol Stream, Illinois
    Posts
    1,695
    Images
    118
    Rep Power
    105

    Re: Question on Serializer WL

    I'm not sure on the power and LED questions, but make sure you are on the correct port. To do this, first unplug the serializer from the computer. Then, right click on My Computer, go to Manage and in Device Manager, expand Ports. Now plug in your serializer and you should see a new port appear. This is the port you need to use.

    �In the long history of humankind (and animal kind, too) those who learned to collaborate and improvise most effectively have prevailed�
    - Charles Darwin

  6. Re: Question on Serializer WL

    Thanks for your reply. I already tried this though and the device manager tells me COM13, which I did input into the code...and the serializer still ignored me.

  7. #7
    Join Date
    Dec 2009
    Location
    San Francisco
    Posts
    45
    Rep Power
    32

    Re: Question on Serializer WL

    yes, you do need to have power other than the little bit (2-3v?) provided by the USB/serial port (which is way below the 9v recommended for the processor on the serializer board, but enough to dimly light the LEDs!). You can simply use a regular 9v battery to test, though a power supply with at least 1-2 A is better. In general, I have found that insufficient power is the number one issue in making robots work the way you "expect".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Project Jim and the Serializer - Part 1
    By JimH in forum Arbotix, Microcontrollers, Arduino
    Replies: 8
    Last Post: 10-12-2008, 01:30 PM
  2. serializer with banebots controller
    By csdude in forum Arbotix, Microcontrollers, Arduino
    Replies: 6
    Last Post: 07-21-2008, 03:37 PM
  3. serializer WL
    By csdude in forum Arbotix, Microcontrollers, Arduino
    Replies: 4
    Last Post: 07-14-2008, 11:33 PM
  4. Interesting Serializer and <Your OS Here>
    By LinuxGuy in forum Arbotix, Microcontrollers, Arduino
    Replies: 8
    Last Post: 03-24-2008, 11:19 PM
  5. Project Jim and the Serializer - Part 2
    By JimH in forum Arbotix, Microcontrollers, Arduino
    Replies: 5
    Last Post: 02-26-2008, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •