Results 1 to 2 of 2

Thread: SOLVED: Arbotix + Arduino IDE + Ubuntu + Invalid Device Sig

  1. #1
    Join Date
    Apr 2007
    Location
    Lititz, PA
    Posts
    52
    Images
    3
    Rep Power
    41

    Exclamation SOLVED: Arbotix + Arduino IDE + Ubuntu + Invalid Device Sig

    Okay so I am in the middle of the PhantomX build, getting ready to wire up (think I need to order up some cables - help Matt!!! - I was messing with bioloid kit cables, not quite cutting it) - so I decide let's get the Arbotix up and running. Works great on Windows, but I wanna mess with ROS and Ubuntu is the way to go, so I got my Ubuntu 10.10 VM running, FTDI all installde /dev/ttyUSB0 is good to go, I hook up the Arbotix which in windows I setup to echo serial so I can make sure it's connected. Arduino IDE Serial Monitor fired up connected to Arbotix board and Hello there serial print comes up, I am connected.

    Now I try to upload a sketch - bam - invalid device sig, yuck, did some searching on this - found the answer, I haven't seen it posted and I remember following the PhantomX thread. It's easy easy fix.

    If you followed the Arbotix Arduino IDE setup, then in your sketches/hardware/ is board.txt - this is all I did:

    # To use an ISP: uncomment the next line, comment out the protocol line
    #arbotix.upload.using=avrispmkii
    #arbotix.upload.protocol=stk500
    arbotix.upload.protocol=arduino

    commented out "stk500" and setup "arduino" tada, I updated my sketch to "Hello Ubuntu" uploaded and in serial monitor I was rewarded with a welcome to Ubuntu

    Chuck Durham
    "cdraptor"
    Last edited by lnxfergy; 01-22-2011 at 07:23 PM. Reason: updating title

  2. #2
    Join Date
    May 2008
    Posts
    2,228
    Images
    155
    Rep Power
    127

    Re: Arbotix + Arduino IDE + Ubuntu + Invalid Device Sig FIX!!

    Just as a follow up, from discussion we just had in the chat room. This fix is applicable to those users who install Arduino IDE through apt-get on Ubuntu. The website download from arduino.cc comes with a custom version of avrdude, which doesn't require this patch.

    Edit: I've added a note on this to the ArbotiX wiki Getting Started page.

    -Fergs
    Last edited by lnxfergy; 01-22-2011 at 06:41 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •