Page 7 of 8 FirstFirst ... 345678 LastLast
Results 61 to 70 of 71

Thread: PhantomX won't move

  1. #61

    Re: PhantomX won't move

    From what I can tell, your servos are not working at all?

    I retried running the AX12 program with Arduino 1.0.6 using the libraries and hardware defines from the Trossen webpage. I then changed my AX12 test program to default to using ax12.h and bioloidController.h if i am not building on a Teensy....

    I ran it again on my Quad (compiled for Hex) and it worked fine. When I hit the 1 command, all of the servos went to their default locations, like: Click image for larger version. 

Name:	Quad-center.jpg 
Views:	42 
Size:	43.6 KB 
ID:	6887
    I could then query the servo positions and the like.

    So if this is not happening on your Hex following similar steps, might need to stand back and check a few more things.

    Like: What power are you feeding to the system? Are you providing 12v wall wart or 3s Lipo power to the system?
    Have you measured the power to make sure?

    I would then try disconnecting all of the servos and then maybe try to connect just 1 leg and then try the find all servos (and or get servo positions command) and see if it finds the 3 servos for that leg, if not try a different leg... If it finds the ones of one leg plug in another leg and try... If none of the legs fully work, disconnect the cables from the first servo of a leg to only have the coxa servo connected and see if it can find it.

    Again I assume you set all of the servo IDS to match the servos that are in the PhantomX MK3 build manual?

  2. Re: PhantomX won't move

    The only difference, with your configuration It seems to be the Yellow jumper from D15 to A7

    it's maybe possible that some cable are damaged? I think about bot, because if that was the case, it wouldn't be switched on. You know?

  3. #63

    Re: PhantomX won't move

    Yes that is one of several possibilities. Which is one of the reasons to do the steps I mentioned in previous posting.

    Some of the other things include:

    Also be wrong voltage power supply coming in. Example a 5v wall wart, which is enough to run a processor, but not enough to run the servos (been there, done that). Or trying to run on a Lipo battery that has run to a really low voltage (if it is that low it is probably unsafe to use...) Also check the jumpers on the board. Example are you running on VIN or USB power?

    Other jumpers on board correct? For example J1 (I think it is called) is set to connect RX to TX which is needed to talk to Dynamixel servos...

    All of the servos still have servo ID #1 - Have seen a few people forget to go through the step to set servo IDs for their servos.

    Software is corrupt - Again option to do like I did yesterday and redownload the trossen hardware and libraries, delete (or rename) existing library and hardware folders in your sketch folder and use fresh copy. (Also update to my latest version of AX sketch). Obviously make sure it fully compiles and installs... (Again I think in long run you are better off with latest Arduino 1.8.1 and later libraries, but I did verify the really old stuff still functions)


    So again I would try the steps I outlined in previous posting.

    Edit: As for my jumper, you are probably talking about my wired in resistor voltage divider that allows me to check the battery voltage using an analogRead instead of asking servos. Again the code to use this was disabled...

  4. Re: PhantomX won't move

    Dear KurtE,

    maybe I've resolved, or better, I've found the issue.

    There are some cables damaged, so now I've to buy another cables set...

    I think this, because with more attention, I've tried again all test programs: HexapodTest, pypose and AX12_test.

    All programs work, but some servos work in the right way fixing cables.

    We really didn't need this ! ! !

  5. #65

    Re: PhantomX won't move

    Sorry to hear this.

    Did you follow the instructions for installing the wires (Step 11 in ?

    They usually do a good job in having your route the wires such that they avoid being pinched, which can lead to shorts and or open connections. Also when i am doing it, I try to move the servos around and visually check for those types of conditions.

    Glad though you localized down the problem

  6. Re: PhantomX won't move

    Now I Will try to find the cable broken with a multimeter...

  7. Re: PhantomX won't move

    Dear All
    I recently bought, PhantomX AX Metal Hexapod Mark III Kit with AX-18 servos, I have assembled the complete Robot following all the instructions provided in Learning website of Trosson. However when I try to load the Hexapod Test program, I am getting this error on the screen - avrdude: stk500_getsync(): not in sync: resp=0x00

    Attaching some photos of the assembly, I tried uploading 'Blink" program but getting the same error. I double checkd all the wiring, power jumper, power voltage every thing seems to be fine. When I plugin the power adaptor which came with the kit, all the servos becomes stiff / tight but none of them moves as shown in the test program video.

    Can some one in this forum Click image for larger version. 

Name:	1.JPG 
Views:	43 
Size:	121.3 KB 
ID:	6904Click image for larger version. 

Name:	2.JPG 
Views:	37 
Size:	117.5 KB 
ID:	6905Click image for larger version. 

Name:	3.JPG 
Views:	41 
Size:	109.8 KB 
ID:	6906Click image for larger version. 

Name:	4.JPG 
Views:	35 
Size:	83.2 KB 
ID:	6907Click image for larger version. 

Name:	5.JPG 
Views:	32 
Size:	90.5 KB 
ID:	6908Click image for larger version. 

Name:	6.JPG 
Views:	36 
Size:	81.8 KB 
ID:	6909Click image for larger version. 

Name:	7.JPG 
Views:	37 
Size:	92.9 KB 
ID:	6910Click image for larger version. 

Name:	8.JPG 
Views:	35 
Size:	109.5 KB 
ID:	6911please help me resolve this issue ?

    Thanks and Regards

    Anbu Kumar
    Cell Number +91-86603-79858
    Bangalore, India

  8. #68

    Re: PhantomX won't move

    First suggestion: I believe that Trossen Robotics uses email and the like to do support, so you might also try to contact them through: email

    Some of the things I would try include and or things to look at include:
    a) How is the board powered? I could not tell from your pictures if the power jumpers were for VIN or USB? I would probably try both ways. That is if it is set to VIN that assumes you have power going to the board through the 12v wall wart or lipo battery.
    I always first assume power issues. If you look at the arbotix documents like:

    If you have a volt meter, I would check that when I am plugged in to either VUSB or VIN, I would check things like do I have +5v on the pins that say they should have +5v?

    b) I would probably start off with everything unplugged from the arbotix board except the FTDI cable and power set to VUSB. Can you download blink to this board? Note: I don't remember which pin LED is on... But simple to find out...

    c) What version of Arduino are you using? I am assuming their default setup with the very very old Arduino 1.0.6... Did you properly copy in the Hardware and library sections to the appropriate places? What board type did you setup the Arduino to use?

    Personally I refuse to use this old version and use current versions of Arduino.... Something along the line what is described in the thread:

    d) Do you have the correct com port selected? Windows or Mac or Linux? What version... Are you able to use this FTDI/XBEE adapter to talk to the XBee? i.e. your machine can talk to the proper Serial port? Note: I have had one of these FTDI adapters fail on me... If by chance you have another FTDI cable, you might try it and see if it works or not. I also assume from your pictures that when you try to program the Arbotix-m, that you do not have an XBee installed in either the Arbotix-m nor in the FTDI adapter.

    e) There is always a change that your Arbotix-m for some reason does not have a boot loader. Do you by chance have an AVR programmer? Like the one they sell ( If so it is so much nicer to use the Arbotix-m as you don't have to remove XBee to program.... If you have one of these, then you might try to upload using it...
    I believe that one needs programmer set to AVR ISP MK2 (Serial)... And/or you can use it to burn bootloader.

    Again sorry for the shotgun answer, as hard to know... And again you may want to directly contact Trossen.


  9. #69

    Re: PhantomX won't move

    The Phantom and Arbotix stuff works with Arduino 1.6 now, which is much better than 1.0!

    Separately, I highly recommend using a programmer, rather than a serial port. As you say, that way you don't have to worry about the Xbee getting in the way. The programmer doesn't have to be of type AVRISPmk2 -- that just happens to be the type that the serial bootloader emulates. USBTinyISP (a k a USBTiny) and USBASP are popular other programmer tools, often available cheaper than the AVRISP (from places like eBay...)

    Anyway, Kurt's one-step-at-a-time approach to troubleshooting is good; try it! And, if somehow none of those steps work, then you have to keep reducing things to first principles -- the first thing that should work is X, so let's set up a simple case where I can verify X works. Then, once I know that works, the second thing that should work is X+Y, so set up a simple case where I can verify X+Y. Keep going, and you'll find the issue! (Or you will get all the way to "everything works," which will be good, too :-)

  10. Re: PhantomX won't move

    Dear KurtEck,

    finally, after many problems, it works!
    In order to find a solution for the damaged cables, I tried (because of the high import price in Italy) to buy the single components (Pin, connectors cables and crimping tools) and do them by myself but they didn't work.
    After all, I decided to buy them from Trossen in order to find a solution for my problem.
    I posted a video in order to show you my PhantomX.

    So my project can go a head

    Best regards...
    Last edited by minimalfra; 05-21-2017 at 02:50 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Ultimate PhantomX Hexapods and Quadropods thread
    By RobotAtlas in forum Humanoids, Walkers & Crawlers
    Replies: 18
    Last Post: 03-22-2011, 11:15 PM
  2. Trouble compiling PhantomX Hexapod Sketch
    By Gilrock in forum Software and Programming
    Replies: 7
    Last Post: 01-31-2011, 11:50 AM
  3. Sneak Peak: InterbotiX PhantomX Hexapod
    By DresnerRobotics in forum Humanoids, Walkers & Crawlers
    Replies: 14
    Last Post: 11-08-2010, 09:23 AM
  4. Question(s) Writing an educatonal book on robotics
    By darkback2 in forum Robotics General Discussion
    Replies: 107
    Last Post: 05-24-2010, 11:51 PM
  5. You can synchronously move multiple dynamixel servos...
    By kbv2842 in forum Humanoids, Walkers & Crawlers
    Replies: 0
    Last Post: 03-05-2008, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts