Results 1 to 5 of 5

Thread: MINI Robocontroller sketch issues

  1. Talking MINI Robocontroller sketch issues

    Just got my MINI Robocontroller in the mail along with some other goodies. Whenever I try to upload a sketch to it I get the error: "avrdude: stk500_recv(): programmer is not responding". I've tried messing around with the reset button and I'm pretty sure I have the right board and usb port selected. Board is running off a 6v battery pack and appears to power on fine. I'm using the sparkfun FTDI breakout. The only thing I noticed that might be contributing to the problem is that on the back of the FTDI breakout board there is no solder on the 3.3v/5v solder pads. However this particular chip appears to be a more recent revision than the one shown, so I'm not sure that even matters. Any help is much appreciated, I can't wait to get this thing working

  2. Re: MINI Robocontroller sketch issues

    Oh the shame... it appears that in my haste to play with the new toy I had plugged the breakout board in backwards. I now know that GR means green and not ground. Now when I try to upload a sketch I get:

    avrdude: stk500_getsync(): not in sync: resp=0x82
    avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x82

    Still doesn't work, I don't really feel like I know enough about this stuff to trouble shoot it myself yet...

  3. #3
    Join Date
    Apr 2010
    Location
    AZ and CA.
    Posts
    383
    Rep Power
    37

    Re: MINI Robocontroller sketch issues

    Please provide a link to the model of controller you have?

  4. Re: MINI Robocontroller sketch issues

    http://www.trossenrobotics.com/p/min...ontroller.aspx

    I have since gotten it to work by switching the board selection in the arduino environment. The robocontroller manual says to use "Diecimila, Duemilanove, or Nano w/ ATmega168", however I have only been able to get mine to work by selecting "Duemilanove, or Nano w/ ATmega328".

  5. #5
    Join Date
    May 2008
    Posts
    2,228
    Images
    155
    Rep Power
    125

    Re: MINI Robocontroller sketch issues

    Quote Originally Posted by draikani View Post
    http://www.trossenrobotics.com/p/min...ontroller.aspx

    I have since gotten it to work by switching the board selection in the arduino environment. The robocontroller manual says to use "Diecimila, Duemilanove, or Nano w/ ATmega168", however I have only been able to get mine to work by selecting "Duemilanove, or Nano w/ ATmega328".
    Yep, we switched to Mega328 chips a while ago, I guess the manuals never got updated.

    -Fergs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trouble compiling PhantomX Hexapod Sketch
    By Gilrock in forum Software and Programming
    Replies: 7
    Last Post: 01-31-2011, 11:50 AM
  2. Mini RoboController /Target Panel Setup
    By elaughlin in forum Mech Warfare
    Replies: 10
    Last Post: 12-12-2010, 10:30 PM
  3. News/Announcement arbotiX Robocontroller Now Available!
    By DresnerRobotics in forum Arbotix, Microcontrollers, Arduino
    Replies: 16
    Last Post: 10-14-2009, 03:22 AM
  4. Problems with Scorpion Mini
    By Dunham in forum Arbotix, Microcontrollers, Arduino
    Replies: 2
    Last Post: 03-17-2007, 05:54 PM
  5. Scorpion Mini question(s)
    By xyzzy1126 in forum DYNAMIXEL & Robot Actuators
    Replies: 7
    Last Post: 02-21-2007, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •