Results 1 to 4 of 4

Thread: USB2Dynamixel in Ubuntu Natty

  1. #1
    Chmaanta Guest

    USB2Dynamixel in Ubuntu Natty

    Hi everyone,
    I think I'm having a driver problem and I need some serious wisdom from experts.

    I have a USB2Dynamixel and a couple of AX12's. I've been trying for a couple of weeks now to get them to run in ROS Diamondback under Ubuntu Natty. Using three different packages they all come back with a message that essentially says "We can see /dev/ttyUSB0, but we can't talk to it".

    When I go to the manufacturer's website they have driver installations for Linux, but it's poorly written and seemingly outdated. i.e. the Makefile is several versions back. They do say however that you need to change some things inside the code and compile so it leads me to believe I can't just plug the USB2Dynamixel in and run. However, I'm not smart enough to figure out how to create the driver for Natty.

    Has anyone struggled with the same problems and been able to slog through it?

    I have run the USB2Dynamixel and the AX12's successfully in Windows 7 so I know it's not a hardware problem.

    Thank you for any help!


  2. #2
    Join Date
    May 2008
    Rep Power

    Re: USB2Dynamixel in Ubuntu Natty

    Try adding yourself to the "dialout" group (and then log out and back in for it to take effect).


  3. Re: USB2Dynamixel in Ubuntu Natty

    Dear ALL.
    I also meet the similar problem, I want to know the details how to set and make use2dynamixel can works under ubuntu 12.04 64 bit.
    do you need to do some file setting and compiling before we plug the device to program for it, In fact, I repeat the steps shown on the website, although there are no related files in /usr/src/lin///. while Ican not do make.
    So I can not use the device now.
    Thanks for any help let me know how to use it under ubuntu 12.04

  4. #4
    Join Date
    Sep 2010
    Rep Power

    Re: USB2Dynamixel in Ubuntu Natty

    The USB2Dynamixel uses the very common FT232RL USBtoUART IC. Drivers for the FT232RL have been in the linux kernel for several years, so you will never need to compile your own. It will show up as "/dev/ttyUSB0" or as a very similar name if you type
    ls /dev | grep tty
    into a terminal. If you cannot access the USB2Dynamixel without using 'sudo', then see if you are in the dialout group by typing "groups" into a terminal. If you do not see 'dialout' listed, then add yourself to that group by typing
    sudo usermod -aG dialout $USERNAME
    into a terminal, where '$USERNAME' is replaced with your username.

    I had the same problem with the Arduino IDE and an Arduino Uno (uses different USBtoUART IC), but adding myself to "dialout" fixed it.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    gives free advice only on public threads

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Roboard ubuntu installation problem
    By moogly in forum Arbotix, Microcontrollers, Arduino
    Replies: 0
    Last Post: 04-17-2011, 08:19 AM
  2. SOLVED: Arbotix + Arduino IDE + Ubuntu + Invalid Device Sig
    By cdraptor in forum Humanoids, Walkers & Crawlers
    Replies: 1
    Last Post: 01-22-2011, 07:34 PM
  3. Question(s) FTDI USB Breakout driver on Ubuntu
    By zzl1007 in forum Arbotix, Microcontrollers, Arduino
    Replies: 4
    Last Post: 11-19-2010, 03:39 PM
  4. Trying PyPose with a USB2Dynamixel
    By Pi Robot in forum Software and Programming
    Replies: 2
    Last Post: 08-23-2010, 06:01 PM
  5. Strage Problems with usb2dynamixel
    By isermann in forum Arbotix, Microcontrollers, Arduino
    Replies: 4
    Last Post: 03-21-2010, 06:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts