Page 7 of 7 FirstFirst ... 34567
Results 61 to 66 of 66

Thread: USB2AX v3.0a feedback

  1. #61
    Join Date
    Sep 2008
    Location
    Toronto, Ontario
    Posts
    171
    Images
    43
    Rep Power
    40

    Re: USB2AX v3.0a feedback

    Quote Originally Posted by Xevel View Post
    My idea would have been to limit the whole number of , so that if you wanted you could query the whole register table of 3 servos at once, but I never took the time to implement it. If you think this could be of help to you, either hack away or I could make a patch for you
    Great! Thanks for the input. I will play with it as is for a bit to get a feel for it and then play with updating the firmware. I'll let you know how that goes.

  2. Re: USB2AX v3.0a feedback

    Ok, so to update the firmware I made a few tools and stuff, and... never actually released them.
    To my defense, you are the first one (except iBot, but he was not using the same hardware as far as I know) to talk about changing the firmware since I released.
    The documentation about firmware update is full of FIXME... hope you can get by with it :/ (shame, SHAAAAAME on me ).
    ---
    Personal blog: http://xevel.org
    USB2AX documentation: http://xevelabs.com

  3. #63

    Re: USB2AX v3.0a feedback

    Thanks Xevel!

    I went up to your website and looked around. Lots of great stuff. I downloaded the sources as I thought it would be fun to experiment adding some functionality. But thought I should first build the current stuff.

    I am building on Window 7 and I believe I have the latest version of Winavr installed (WinAVR-20100110). When I go to the directory soft\lufa_usb2ax and do a make all, the compile fails as clock_div_1 is not defined:
    Code:
    C:\Users\Kurt\Desktop\USB2AX\soft\lufa_usb2ax>make all
    
    Begin compilation of project "USB2AX"...
    
    avr-gcc (WinAVR 20100110) 4.3.3
    Copyright (C) 2008 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    
     [GCC]     : Compiling C file "USB2AX.c"
    avr-gcc -c -pipe -gdwarf-2 -g3 -mmcu=atmega32u2 -fshort-enums -fno-inline-small-
    functions -fpack-struct -Wall -fno-strict-aliasing -funsigned-char -funsigned-bi
    tfields -ffunction-sections -I. -I../../LUFA-120730/LUFA/.. -DARCH=ARCH_AVR8 -DB
    OARD=BOARD_USB2AX_V31 -DF_USB=16000000UL -DF_CPU=16000000UL -x c -Os -std=gnu99
    -Wstrict-prototypes -DUSE_LUFA_CONFIG_HEADER -IConfig/  -MMD -MP -MF USB2AX.d US
    B2AX.c -o USB2AX.o
    USB2AX.c: In function 'setup_hardware':
    USB2AX.c:438: warning: implicit declaration of function 'clock_prescale_set'
    USB2AX.c:438: error: 'clock_div_1' undeclared (first use in this function)
    USB2AX.c:438: error: (Each undeclared identifier is reported only once
    USB2AX.c:438: error: for each function it appears in.)
    make: *** [USB2AX.o] Error 1
    Suggestions? Should I try under Linux instead? Note: I am pretty sure I can figure out a workaround for this as I suspect that it is needing some system header file or the names in some header changed.

    Thanks again
    Kurt

    EDIT: Compiled fine when I rebooted to Linux Mint. Probably some configuration information on my machine.... Sorry
    Last edited by KurtEck; 11-15-2013 at 03:32 PM.

  4. Re: USB2AX v3.0a feedback

    WinAVR old stuff. Much deprecated. :/

    For the last few years, I have been building AVR stuff with Atmel Studio (6.1 now), they have a relatively more recent toolchain (avr-gcc (AVR_8_bit_GNU_Toolchain_3.4.2_992) 4.7.2), and now LUFA is even available as an extension (very handy). The (big) downside of course is that you have to install all this gigantic package, etc... and their f**king website that asks you to register to even download it - slowly...

    If you really want to compile with WinAVR anyway, you can add somewhere in the header the definition of clock_div_1 ( http://www.nongnu.org/avr-libc/user-.../power_8h.html ) from and it should work - until the next problem arises. Old versions of the main header file even had a #ifdef to add that definition if it was not present.

    Actually, I had a lot of problems back in the days when I had both WinAVR and AVR studio (the atavistic form of ATMEL studio), the path of both would collide, and a lot of bad stuff happened. The fix was to change the order of the declarations in the PATH to lure the scripts to find into finding the right version of the tool they needed.
    But soon after, I cleaned everything up, installed only one tool (AVR studio) and never looked back.
    Last edited by Xevel; 11-15-2013 at 03:54 PM.
    ---
    Personal blog: http://xevel.org
    USB2AX documentation: http://xevelabs.com

  5. #65

    Re: USB2AX v3.0a feedback

    Thanks,

    I used to use AvrStudio 3.x and the like, but did not install it on this machine as it wanted to update firmware in AVRISP MK2 and then avrdude (Arduino) would not be able to use it... But I now have it downloading 6.1 (will take awhile)

    I could probably get it to work with Winavr stuff, but might as well clean it up to the more recent stuff.

    Side comment: On your product technical spec page: http://www.xevelabs.com/doku.php?id=...t:usb2ax:specs
    I believe the Atmega32u2 only has 1K of ram (32u4 has the 2.5k)

    Thanks again

  6. Re: USB2AX v3.0a feedback

    Quote Originally Posted by KurtEck View Post
    Side comment: On your product technical spec page: http://www.xevelabs.com/doku.php?id=...t:usb2ax:specs
    I believe the Atmega32u2 only has 1K of ram (32u4 has the 2.5k)
    You are perfectly right, fixed Thanks
    ---
    Personal blog: http://xevel.org
    USB2AX documentation: http://xevelabs.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Regarding Dynamixel Positional Feedback Demo
    By DiegoSpinola in forum Robotics General Discussion
    Replies: 4
    Last Post: 12-06-2011, 05:09 PM
  2. Project Handmade 5DOF Manipulator with tactile feedback
    By Antonb in forum Project Showcase
    Replies: 9
    Last Post: 03-11-2011, 05:50 PM
  3. Question(s) Using AX-12's present-load feedback
    By RobotAtlas in forum Humanoids, Walkers & Crawlers
    Replies: 1
    Last Post: 07-04-2010, 08:33 PM
  4. Question(s) Pololu 3A Motor Controller with Feedback
    By kankatee in forum Arbotix, Microcontrollers, Arduino
    Replies: 4
    Last Post: 12-22-2008, 07:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •