Results 1 to 3 of 3

Thread: Turtlebot arm servos not being recognized

  1. Turtlebot arm servos not being recognized

    I am using a turtlebot arm and just finished getting the ROS sketch uploaded to the ArbotiX board when I ran into an error. I run the command to search for the servos after having plugged only one into the board and get the following result:
    [email protected]:~$ rosrun arbotix_python /dev/ttyUSB0
    ArbotiX Terminal --- Version 0.1
    Copyright 2011 Vanadium Labs LLC
    >>  ls
    .... .... .... .... .... .... .... .... .... 
    .... .... .... .... .... .... .... .... .... 
    I have tried multiple cables and multiple servos to see if either was the problem. Neither of them turned out to be the problem. I have established that the servos do at least move, since I was able to issue them commands using PyPose. The only concern that I have is the the red light on the servos first light up when I plug them in, but do not stay lit for more than a second. I am currently running the arbotix board directly off of a iRobot Create battery (as opposed to going through the power board, since the only port on my power board is being occupied by the create). I don't think that should cause a problem, but figured I would mention it. Does anyone have an idea why my computer cannot read the servos, or any recommendations for other troubleshooting steps to take? Thank you very much!

  2. #2
    Join Date
    May 2008
    Rep Power

    Re: Turtlebot arm servos not being recognized

    I've replied on Please don't cross post, the ROS experts here will also be on


  3. Re: Turtlebot arm servos not being recognized

    I apologize, I did not realize that the communities were so closely linked. It shall not happen again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Problems using PyPose with the Turtlebot Arm
    By Aroarus in forum Arbotix, Microcontrollers, Arduino
    Replies: 5
    Last Post: 07-15-2012, 12:21 PM
  2. TurtleBot Power and Sensor Board
    By jronald in forum ROS - Robot Operating System
    Replies: 0
    Last Post: 07-10-2011, 09:36 PM
  3. TurtleBot-like hardware platform?
    By wmccafferty in forum Mechanics / Construction
    Replies: 4
    Last Post: 04-21-2011, 10:47 PM
  4. Servos
    By byi in forum Mech Warfare
    Replies: 8
    Last Post: 07-15-2010, 11:51 PM
  5. HITEC Servos: Can the OEM RN-1 Servos handle 7.4V?
    By MYKL in forum DYNAMIXEL & Robot Actuators
    Replies: 10
    Last Post: 06-23-2008, 04:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts