Trossen Arduino Top Thread
Results 1 to 6 of 6

Thread: First time getting PhantomX Turret + ArbotiX Going

  1. First time getting PhantomX Turret + ArbotiX Going

    Hello,

    I'm new to both the ArbotiX and Dynamixel components. I'm well versed in Atmel chips and general programming.

    I constructed my PhantomX board and I'm looking to just test everything then write a simple python server that can control the turret for me. I'm using the CommEXT.py script to test basic functionality / movement. I am currently unable to get the actuators to move.

    Here is what I get:

    Code:
    ./CommEXT.py /dev/tty.usbserial-A400C242 -1
    -1
    -1
    -1
    -1
    -1
    -1
    -1
    Digital: -1
    Here is what I've troubleshooted
    • Power is on and LED is lit
    • FTDI wire is correct orientation (tried both orientations, command fails on both, status light only flickers with correct orientation)
    • Power jumper set for VIN
    • J1 Jumper set to tie RX/TX, although I also tried toggling it.
    • Tried changing order of cables into Dynamixel
    I can not confirm that the Comm_EXT firmware is loaded onto my ArbotiX board but this is what the turret manual says. I see the same output from CommEXT.py when the FTDI cable is connected to the ArtbotiX and when it is disconnected.

    Does anyone have any ideas? I can burn the Comm_EXT if necessary, I assume this is CommExt.pde.
    thanks!

  2. Re: First time getting PhantomX Turret + ArbotiX Going

    Commander Firmware was not loaded despite manual claims, had to compile and load. Works now.

  3. #3
    Join Date
    May 2008
    Posts
    2,230
    Images
    155
    Rep Power
    110

    Re: First time getting PhantomX Turret + ArbotiX Going

    Trossen stopped uploading firmware some time ago I believe. The product page has been updated, but the manual is still out of date. I'm sure they'll get it updated soon.

    -Fergs

  4. Trossen Hexapod  Thread Banner
  5. Re: First time getting PhantomX Turret + ArbotiX Going

    Hello,

    I'm a complete green horn when it comes to programing, but I like to learn new things and try and figure things out. I got a dumb question I'm hoping someone could help point me in the right direction.

    I have a Phantom X Robot Turret, and I was wonder if I should load the Comm_EXT Proportional sketch onto the Arobotix board before trying to setup control using Roborealm?

    Listed below is my hardware/software setup:

    Windows 7 64 bit
    Arduino 0018
    Python 2.7.3
    wxPython2.8-win32
    pyserial-2.5.win32
    PhantomX-Robot Turret with 2 each AX-12A servos
    ArbotiX robocontroller - FTDI usb cable
    Roborealm

    Thanks for the help.

  6. Re: First time getting PhantomX Turret + ArbotiX Going

    you upload the CommExt applet

  7. Re: First time getting PhantomX Turret + ArbotiX Going

    Is there GUI software available that emulates the Arbotix Commander?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Programming the PhantomX Robot Turret
    By dandbd in forum Arbotix, Microcontrollers, Arduino
    Replies: 53
    Last Post: 06-02-2012, 09:46 PM
  2. Question(s) PhantomX Turret Problems
    By sirching in forum Software and Programming
    Replies: 0
    Last Post: 03-10-2011, 09:18 PM
  3. Battery run time
    By rebel in forum Robotics General Discussion
    Replies: 1
    Last Post: 02-26-2011, 10:18 AM
  4. 1st time RoboGames attendee
    By Stobs in forum Mech Warfare
    Replies: 8
    Last Post: 04-06-2010, 12:06 AM
  5. Time Limit?
    By Firestorm65 in forum Mech Warfare
    Replies: 26
    Last Post: 03-15-2009, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •