Hi guys, long time lurker here, but I'm having a problem and finally decided it'd be a good idea to register.


Anyway, here's the deal. I have a Lynxmotion Phoenix powered by an ARC32. The thing was working fine for months, and then I got the bright idea to disassemble it and clean up some wiring. Long story short, somehow I fried the reciever for the wireless PS2 controller.

Normally, when you turn the bot on, one light on the rx comes on and the other blinks, once it makes a connection they both stay on. Now what happens is one light comes on, the other never comes on and the bot wont respond to the controller.

I bought another controller thinking maybe I messed up the rx when I took the housing off of it to save some space. When the new one came in, I plugged it in and it seemed to connect. Both lights came on. Then I pressed the start button to send the servos to their home position and the second I did that, the second light went out on the rx and again it wouldn't respond to the controller.

Thinking the rx was just defective, I returned that one and tried another. Well, same thing. I think it's doubtful I got two bad ones in a row.. But what I cant understand is why it would fry itself the very second the servos jumped. I didn't change any wiring or anything since the last time it worked.


If I load a program to test the PS2 controller's input, and plug in a hardwired Sony brand PS2 controller, it will correctly read the buttons, but running the regular code the robot still won't respond to it.



I have absolutely no idea what's going on here, but I'm open to any suggestions... Any help is appreciated.