Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: MX-64T half-dead H bridge?

  1. #1

    MX-64T half-dead H bridge?

    After having my new quad trying some "air gaits" while suspended on a pedestal, I noticed that one of the servos didn't move right.
    Taking it loose and testing it with Dynamixel Wizard, I find that it moves in one direction, but not the other.
    To me, that feels like a burnt leg on an H-bridge.

    I vaguely recall a subject similar to this being discussed before in this forum, but can't find the thread.
    My main question is whether this is something I somehow caused by making the robot walk in air, or whether it's possibly some defect in manufacture.
    If it's the former, then I'd very much like to understand what the problem is, and how to prevent it from happening again... I haven't been putting hardly any load on these; my power supply has been idling at 1A with movement maybe getting it to 2A for a full 12 servos.

  2. #2
    Join Date
    Sep 2010
    Location
    ಠ_ಠ
    Posts
    2,313
    Images
    27
    Rep Power
    279

    Re: MX-64T half-dead H bridge?

    You could take the electronics side cover off to visually inspect the H-bridge ICs. Just be sure to hold the other (non-LED) side of the case firmly against the center portion so that the gear set doesn't fall out. It is not impossible, but quite annoying to put back together if you don't have a way to easily pull the horn off the output spline (other gears fit over the main output gear, so it must be seated before adding the other gears. an extra horn and a couple M2 screws work wonders in removing horns).
    Back on topic, if there is a dead H-bridge it should be fairly obvious with the smell and/or deformation of the IC package. You might even end up with the insulation of one of the wires used to link the two molex connectors melted onto the IC package if it was touching during failure. Causes vary, but not completely pulling power and letting it cool after an overheating error can damage the motor which absolutely will cause failure of the H-bridge (usually complete seizure of the rotor, but sometimes just very difficult to turn. For us, the driver burns out during the next use before the servo catches it as MX-28 have no current measurement). The fact that it still moves in one direction means the motor should still be working fine, but you will probably want to not use it anymore and arrange an RMA with Robotis (or you risk further damage and costs for repair/replacement).
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    [git][mech][hack]
    gives free advice only on public threads

  3. #3

    Re: MX-64T half-dead H bridge?

    if there is a dead H-bridge it should be fairly obvious with the smell and/or deformation of the IC package
    Thanks! I'd expect that if I ever ran the things hard enough to develop any heat. I've been monitoring heat, current, and load, and none of them have gone much beyond idle during this testing. That's what's so weird!

    I do want to arrange an RMA anyway (I have a spare servo I screwed in place) but I'd like to understand if there's any reason other than simply running them too hard for something like this to fail. Something like, say, whiplashing motions generating too much feedback voltage and exceeding the breakdown threshold of the MOSFETs. If that's a real possibility, and the Dynamixels aren't protected against that, then I want to be as paranoid as poissible!

  4. #4
    Join Date
    Sep 2010
    Location
    ಠ_ಠ
    Posts
    2,313
    Images
    27
    Rep Power
    279

    Re: MX-64T half-dead H bridge?

    With the MX-28, the biggest issue has been overheating the motors and not lettting them cool down completely (must disconnect power, and not just disable torque). That said, the elbows and shoulders have had the most frequent failures while having the least amount of loading. They have been very active by making frequent and rapid motions (waving arms and a little plastic sword), but never heavy loading like pushing the DARwIn-OP up off the ground. The servos pretty much work fine until they overheat one too many times and then get put away for the night; when next taken out of the pelican case, the motor is frozen in place.

    Although it likely took quite a while to damage the motor, the second to last MX-28 to blow up did so in seconds - set goal position, servo does not move, puff of smoke and stench starts filling room, scream and pull power. The last one to die had a motor failure of some sort (rotor seized and suspect the windings shorted out) followed shortly thereafter by part of either H-bridge failing closed causing the motor to become a low ohm power resistor. It took a bit before the power drain caused the CM-530 I was using for testing to start beeping that the battery was getting low. It took a little longer than that for the servo case to start getting warm enough to notice. The only temperature sensor I know to be in the MX-28 is inside the STM32, which is quite far away from the actual motor.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    [git][mech][hack]
    gives free advice only on public threads

  5. #5

    Re: MX-64T half-dead H bridge?

    Sounds like you have a collection of failure cases! A true artist sacrifices everything for the art?

  6. #6
    Join Date
    Sep 2010
    Location
    ಠ_ಠ
    Posts
    2,313
    Images
    27
    Rep Power
    279

    Re: MX-64T half-dead H bridge?

    Five MX-28 with burnt motors and/or H-bridges, two MX-28 with sheared off output splines, one MX-28 with an output gear with a damaged tooth (not horrible, but does affect performance). Grabbed the gear set from one of the totally dead servos to replace the third damaged gear set.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    [git][mech][hack]
    gives free advice only on public threads

  7. #7
    Join Date
    Sep 2008
    Posts
    60
    Images
    2
    Rep Power
    43

    Re: MX-64T half-dead H bridge?

    I think the older rx-28's and dx-117's have a proper pwm ic with a built in thermister. The newer mx-28's and 64's have only an h-bridge which is very similar to the ax-12 design.

  8. #8

    Re: MX-64T half-dead H bridge?

    I really don't think I've overheated these servos. They've been only sitting on a pedestal mounted quad, and I've been running simple gait and IK tests, with a runtime of perhaps 10-20 seconds each, with no load (again, just in air.) If that's able to overheat the servos, then there's no chance that anything real can be built with them. And I've seen lots of cool, real, robots built with these servos :-)

    So, my fear of inductively generated voltages damaging the MOSFETs is unfounded, or unknown-status?

  9. #9
    Join Date
    Sep 2008
    Posts
    60
    Images
    2
    Rep Power
    43

    Re: MX-64T half-dead H bridge?

    The AUK SUF2001 MOSFET's used have a built in reverse body diode http://www.auk.co.kr/pro_upload/SUF2001.pdf
    I
    t's certainly possible that if there is insufficient filtering on the motor or a motor is sufficiently noisy then back emf could overcome the recovery of the body diode and cause such damage. Looking at the board it appears there is only one 0.01 mfd cap across the motor leads and it is on the board between the FET's not on the motor where one would like it. Ideally there would be three of these for the motor, between the motor can and each terminal and between terminals and all right at the motor.

  10. #10
    Join Date
    Sep 2010
    Location
    ಠ_ಠ
    Posts
    2,313
    Images
    27
    Rep Power
    279

    Re: MX-64T half-dead H bridge?

    The SUF2001 was used in the RX-28M and beta MX-28, but the newer MX-28T that died used two FDS6990. The SUF2001 is definitely not available from digikey or mouser, but that may just be lack of demand.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    [git][mech][hack]
    gives free advice only on public threads

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Contest Entry Donna The Dead Bot
    By Rodger Cleye in forum Project Showcase
    Replies: 5
    Last Post: 11-02-2009, 08:34 AM
  2. Question(s) Half PDA/Half Desktop PC
    By DanTheMan in forum Mechanics / Construction
    Replies: 41
    Last Post: 01-14-2009, 02:29 PM
  3. Question(s) H-Bridge problems have me bewildered.
    By gimmelotsarobots in forum Robotics General Discussion
    Replies: 5
    Last Post: 11-08-2008, 12:31 PM
  4. Just For Fun The humans are dead
    By kwan in forum Off Topic
    Replies: 2
    Last Post: 09-14-2008, 01:58 AM
  5. H bridge Design
    By jdolecki in forum DYNAMIXEL & Robot Actuators
    Replies: 3
    Last Post: 07-05-2008, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •