Results 1 to 1 of 1

Thread: TinyXML and ros

  1. TinyXML and ros

    Hi

    I'm trying to create a new proyect, using a library called TinyXML in a node.
    This library is incorpored by default.

    I'm following the steps described in http://www.ros.org/wiki/tinyxml.

    But, when I compile, an error ocurred:
    Code:
    CMake Error at CMakeLists.txt:32 (target_link_libraries):
      Cannot specify link libraries for target "xxxxx" which is not built  by this project.
    This is my CMakeList:
    Code:
    cmake_minimum_required(VERSION 2.4.6)include($ENV{ROS_ROOT}/core/rosbuild/rosbuild.cmake)
    
    
    # Set the build type.  Options are:
    #  Coverage       : w/ debug symbols, w/o optimization, w/ code-coverage
    #  Debug          : w/ debug symbols, w/o optimization
    #  Release        : w/o debug symbols, w/ optimization
    #  RelWithDebInfo : w/ debug symbols, w/ optimization
    #  MinSizeRel     : w/o debug symbols, w/ optimization, stripped binaries
    #set(ROS_BUILD_TYPE RelWithDebInfo)
    
    
    rosbuild_init()
    
    
    #set the default path for built executables to the "bin" directory
    set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin)
    #set the default path for built libraries to the "lib" directory
    set(LIBRARY_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/lib)
    
    
    #uncomment if you have defined messages
    rosbuild_genmsg()
    #uncomment if you have defined services
    rosbuild_gensrv()
    
    
    #common commands for building c++ executables and libraries
    #rosbuild_add_library(${PROJECT_NAME} src/example.cpp)
    #target_link_libraries(${PROJECT_NAME} another_library)
    #rosbuild_add_boost_directories()
    #rosbuild_link_boost(${PROJECT_NAME} thread)
    #rosbuild_add_executable(example examples/example.cpp)
    #target_link_libraries(example ${PROJECT_NAME})
    
    
    target_link_libraries(${PROJECT_NAME} tinyxml)
    
    
    rosbuild_add_executable(send_msg src/send_msg.cpp)
    rosbuild_add_executable(script_player src/script_player.cpp)
    How could I fix it? I'm running ros_fuerte
    Thanks
    Last edited by natanoj; 01-17-2013 at 10:30 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •