Results 1 to 4 of 4

Thread: Compiling Error with Arduin IDE / Pypose : could not read servo error

  1. Compiling Error with Arduin IDE / Pypose : could not read servo error

    Hello all,

    I've just got a hexapod PhantomX ( using AX-18 Servos ). I assembled it and it works properly controlling it wirelessly via the xbee module.

    Concerning a study project, I want to be able to control it via FTDI interface from a computer, that's why I'm currently trying out the interface.

    I guess I set up the Arbotix board in the right way :
    1) plug in the FTDI cable ( using a usb breakout board )
    2) Energy supply : put the jumper to the regulator
    3) removed the xbee module to avoid interference
    4) I am using Dynamixel AX-18 so I tied RX/TX together (J1)

    Now I tried to use Pypose but the program says : could not read servos ,when I try to capture a pose
    When I try to use the terminal an list the servos plugged, that doesn't work neither.
    While capturing, I can see the TX-LED blinking, but no RX ( so there is apparently just flowing one direction )

    I tried out to go further with "minicom"
    and when I switch on the hexpod bot, it displays the voltage in minicom and the RX blinks.

    I also downloaded the Hexapod_Sketch from the trossenrobotics website and tried to compile it, and that's what i get :

    /home/robot/sketchbook/hardware/arbotix/cores/arbotix/Print.cpp: In member function ‘size_t Print:rint(const __FlashStringHelper*)’:
    /home/robot/sketchbook/hardware/arbotix/cores/arbotix/Print.cpp:44:9: error: ‘prog_char’ does not name a type
    /home/robot/sketchbook/hardware/arbotix/cores/arbotix/Print.cpp:47:23: error: ‘p’ was not declared in this scope

    Actually I installed the arduino software as described and can select Arbotix as a board.

    Does any of you guys have any suggestions, how i could solve all this ?

    I'm quiet new in this field and would really appreciate any help.
    Big thanks in advance.

  2. #2
    Join Date
    Sep 2010
    Location
    ಠ_ಠ
    Posts
    2,313
    Images
    27
    Rep Power
    278

    Re: Compiling Error with Arduin IDE / Pypose : could not read servo error

    If you want to use PyPose running on a PC, you have to compile and download the pypose sketch to the arbotix.
    Which version of the Arduino IDE and which version of the arbotix library are you using? The hardware/arbotix folder goes in the Arduino IDE's hardware folder ("C:/arduino/hardware/arbotix/cores/", etc.)
    Are you applying 12V external power to the servos? If they do not get 9.6~12V, they will not do squat even though the arbotix may blink.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    [git][mech][hack]
    gives free advice only on public threads

  3. #3
    Join Date
    Dec 2012
    Location
    Los Angeles, CA
    Posts
    858
    Images
    25
    Rep Power
    88

    Re: Compiling Error with Arduin IDE / Pypose : could not read servo error

    You statement "2) Energy supply : put the jumper to the regulator" implies you are not turning your battery on. The jumper only powers the board via the cable. Not the servos.

  4. Re: Compiling Error with Arduin IDE / Pypose : could not read servo error

    Hi again,

    Okay so if I understood well, I can use Pypose only if the Pypose Sketch is downloaded to the arbotix. But then I have to download the "gait"-sketch again, to use it as before, am I right ?

    I'm using Arduino 1.0.1 and this arbotix version (arbotix-0015)
    https://code.google.com/p/arbotix/do...5.zip&can=2&q=

    I'm using it on Ubuntu, and in the Arduino explanation, I was told to copy the arbotix folder to the sketchbook folder.
    Actually I think that this part worked fine, because I can choose the Arbotix board in the arduino program.
    But I still can't find out why it isn't compiling then.

    I'm applying 12V from an external power supply, so this should be fine.
    I turned the energy supply of the hexapod bot on, while working with it.

    I think even tough it would be good to have Arduino working, it is actually not my absolut need.

    It is meant to control the bot with ROS later on. I'm quiet new in this field and don't know much about it yet, so please excuse any issues that seem trivial to you guys.
    I'm actually okay with the gait mode of the robot and don't want to modifiy it( that's why I don't absolutely need the Arduino software working ),
    but what I want to do is, control it in real-time with basic commands via the PC.

    So I want to be able to sent basic commands to the bot.
    I had a look on the commander manual at the trossenrobotics website.
    Is it possible to use these commands, like : Xspeed = ...or bodyRotZ = ..., to control the bot or how would you suggest to proceed ?

    cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Arduino PyPose Error
    By hwan we in forum Software and Programming
    Replies: 2
    Last Post: 01-29-2013, 07:55 AM
  2. error - not available
    By cillaelery in forum Garage Sale
    Replies: 0
    Last Post: 05-05-2012, 11:05 PM
  3. Question(s) Arbotix Pypose Read failed: servo id X
    By Ron in forum Robot Computers
    Replies: 20
    Last Post: 11-10-2011, 01:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •