Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: unable to compile ArbotiXBlink

  1. #11

    Re: unable to compile ArbotiXBlink

    "I fixed" the ' error: attempt to use poisoned "SIG_USART1_RECV" ' error downloading the Arduino IDE AND unzipping it.

    Using the synaptic version shows that error

  2. #12
    Join Date
    Sep 2014
    Location
    Northern Colorado
    Posts
    7
    Rep Power
    18

    Re: unable to compile ArbotiXBlink

    Quote Originally Posted by CreedyNZ View Post
    Hi,

    I struck this same issue with Ubuntu 14.04 and Arduino 1.0.5

    The following seems to have solved it for me, making the change to the /sketchbook/hardware/arbotix/cores/arbotix/arduino.h file :
    http://wiki.gentoo.org/wiki/Arduino#Known_Bug_147155
    This seems to have worked for me also, thanks CreedyNZ! Maybe someday I'll figure out why, but for today I'll be happy.
    Website I put up on kidney dialysis: http://dialysisethics2.org/

  3. #13

    Re: unable to compile ArbotiXBlink

    Yes the Arbotix Arduino tree is not anywhere up to date.

    I have my own fork of their project, where I updated it to Arduino 1.0.5 code base awhile ago, which I thought they were going to pull it into the main fork. Recently I updated mine to now the 1.0.6 code base. Mine is up at:
    https://github.com/KurtE/arbotix

    Note: I have done some with my fork on both Windows 7 and Ubuntu. I believe I ran some tests on it after I updated my Intel Nuc to 14.04.

    Kurt

  4. #14
    Join Date
    Sep 2014
    Location
    Northern Colorado
    Posts
    7
    Rep Power
    18

    Re: unable to compile ArbotiXBlink

    Looked over your website, I'll have to keep it in mind!
    Website I put up on kidney dialysis: http://dialysisethics2.org/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ros.pde compile error on arduino-0023
    By bellscotcv in forum Arbotix, Microcontrollers, Arduino
    Replies: 1
    Last Post: 07-16-2012, 01:08 PM
  2. malloc no declared error on compile of ros.pde
    By bellscotcv in forum Arbotix, Microcontrollers, Arduino
    Replies: 5
    Last Post: 07-13-2012, 02:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •