Results 1 to 4 of 4

Thread: Odroid C1 Ubuntu 14.04 and wicd and IPv6 issue?

  1. #1

    Odroid C1 Ubuntu 14.04 and wicd and IPv6 issue?

    I am not sure if this Is Odroid specific or mainly wicd? But on my Odroid C1, I thought I would try out an image ( that one of the main users setup for ROS with OpenNI and pCL. It is built around Ubuntu 14.04.2?

    Before this I ran the official build ( and my wifi networking was running fine.

    But with this ROS version, they stripped down the build, changed which screen manager was used and in addition switched to wicd as their network manager.

    With this image none of my wifi adapters work, including the Odroids most recent one (v4). The Gui when I try to connect complains about invalid password, which I know is correct. But looking at dmesg it looks like it is erroring out trying to use IPv6. Note: the member who setup this image only uses wired network, which does work for me... But for Robot I want wireless...

    My strong guess is that my network is not setup for IPv6 and probably only support IPv4. My home networks is a little more complex than normal, with microwave connection to tower, that goes to my main router (Netgear Prosafe), which connects up to several places in my house and does the DHCP. My secondary router (netgear wndr3700) connected to Prosafe which handles the wifi... So not sure in which of these parts do not support IPv6...

    I tried removing wicd and try to go back to network-manager, but network manager was still installed. Tried copying some of the network configurations from working image to this and still no connection.

    So question is, is there an easy way to disable IPv6 and have it only use IPv4, or should I attempt to figure out if it is possible to configure my network to support IPv6?


  2. #2
    Join Date
    Sep 2010
    Rep Power

    Re: Odroid C1 Ubuntu 14.04 and wicd and IPv6 issue?

    Copying files from the working image, or retyping the settings using the network-manager gui? I've never been able to get copied or manually created configuration files to be recognized by network-manager. After using the gui to create configuration files, I've then been able to modify those files to change the settings and still have everything work, but they have to be created by the gui first.
    Please pardon the pedantry... and the profanity... and the convoluted speech pattern...
    "You have failed me, Brain!"
    gives free advice only on public threads

  3. #3

    Re: Odroid C1 Ubuntu 14.04 and wicd and IPv6 issue?

    Thanks, yes I have not had a lot of luck this way either. When I was using the BBBk I did have some luck hand generating the files.

    But my guess is that there probably is some system setting that controls IPv6. I have seen several different things up on Web talking about this, but still not making much sense of it. I think some have done it by disabling something in the boot settings.


  4. #4

    Re: Odroid C1 Ubuntu 14.04 and wicd and IPv6 issue?

    I got the wifi to work

    I first tried to disable IPV6 in ubuntu, by following:

    Still appeared to try to use IPV6 and failed. So I did some searching around and found:

    So I simply hard coded my network stuff into /etc/network/interfaces
    When I rebooted my wifi was up and running


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Building a DarwinOP using Odroid-XU3, video image inverted
    By dmcman73 in forum Robotics General Discussion
    Replies: 4
    Last Post: 04-01-2015, 08:17 PM
  2. Raspberry PI 2 vs. Odroid XU3 to use with Dynamixel SDK and usb2ax
    By Snoopy in forum Arbotix, Microcontrollers, Arduino
    Replies: 3
    Last Post: 02-03-2015, 07:19 PM
  3. Shiny new toy: ODROID-U2
    By Xevel in forum Robot Computers
    Replies: 39
    Last Post: 12-25-2013, 11:10 AM
  4. How do you connect a NUC/Pi/Odroid to a PhantomX?
    By guruguhan in forum Humanoids, Walkers & Crawlers
    Replies: 9
    Last Post: 10-11-2013, 09:53 PM
  5. (Questions) How to use USB2Dynamixel under 64v bit Ubuntu 12.04
    By zhenli in forum Arbotix, Microcontrollers, Arduino
    Replies: 1
    Last Post: 02-01-2013, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts