Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: How to install a functional ROS with KevinO's hexapod_ros on a Raspberry 3?

  1. #21
    Join Date
    Sep 2016
    Location
    Germany
    Posts
    15
    Images
    1
    Rep Power
    11

    Re: How to install a functional ROS with KevinO's hexapod_ros on a Raspberry 3?

    OK, then it's no wonder that there are no relations between the values in the PhantomX-files and Charlotte.
    Then I hope that Renee can give me some hints how to modify the configuration files according to my camera mount. I attached a picture to show, how I made the mount.
    By the way, the F2- and F3-Brackets and servo hubs I printed myself with black PETG because the brackets and hubs coming with the servos have an ugly grey color.
    I also designed and printed a mount for the camera to be attached to the F2-bracket. If there is an interest I can publish this mount on thingiverse.

    Click image for larger version. 

Name:	20161007_225040.jpg 
Views:	191 
Size:	86.2 KB 
ID:	6706
    Last edited by SnowHead; 10-08-2016 at 08:59 AM.

  2. #22
    Join Date
    Mar 2015
    Location
    Texas
    Posts
    342
    Images
    15
    Rep Power
    33

    Re: How to install a functional ROS with KevinO's hexapod_ros on a Raspberry 3?

    I'm heading out of town so I won't be able to help much. If you don't understand how the URDF / xacro file are assembled I recommend following the tutorials.

    http://wiki.ros.org/urdf_tutorial

    in particular you must learn about changing the origins and axis of the joints. See

    http://wiki.ros.org/urdf/Tutorials/B...from%20Scratch
    and
    https://github.com/KevinOchs/hexapod...odel.xacro#L64
    01001001001000000100110001101111011101100110010100 10000001010010011011110110001001101111011101000111 0011

    My Instagram
    My YouTube

  3. #23
    Join Date
    Sep 2016
    Location
    Germany
    Posts
    15
    Images
    1
    Rep Power
    11

    Re: How to install a functional ROS with KevinO's hexapod_ros on a Raspberry 3?

    Thanks for the hints. The posted links I already studied as written earlier.
    The essential clarification especially for the uncomprehensible rotation of the optical frames of Pi/2 around the x-axis came from KevinO explaining that the coordinate system of the optical frames is flipped against the mechanical frames. And that Charlotte is not the source for the default values in the description files explains the discrepances between the awaited and the found values.
    So I'm confident to be able to write the correct configuration files for my camera mount.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) NXT package install error
    By klevison in forum Sensors
    Replies: 1
    Last Post: 11-12-2015, 02:02 PM
  2. ROS: Yet another failed install attempt
    By jwatte in forum Software and Programming
    Replies: 7
    Last Post: 07-12-2015, 05:11 PM
  3. How best to fix up a Linux Install?
    By KurtEck in forum Robotics General Discussion
    Replies: 6
    Last Post: 01-26-2015, 10:26 AM
  4. Question(s) Roboard and Windows XP Install...
    By sniperscope in forum Robotics General Discussion
    Replies: 4
    Last Post: 06-01-2009, 04:53 PM
  5. Linux install
    By sthmck in forum Off Topic
    Replies: 6
    Last Post: 09-02-2008, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •