Results 1 to 5 of 5

Thread: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

  1. Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    Hi all,

    Background: I have a Turtlebot arm (5 AX-12A servos) controlled with a OpenCM 9.04. It worked fine till last week, when I updated ubuntu to 16.04. Of course the update has nothing to do (neither works on windows), but maybe has to do a small electric crackling I got when plugging (incorrectly) another device to the OpenCM

    Current situation:
    • OpenCM seems to work: I can read an analogue, upload programs, get serial data, etc.
    • Servos blink once when plugged, as usual
    • All readings from and writings to the servos fail; they don't move at all. I tried with PyPose and basic Open CM IDE examples that used to work fine
    • Trying to connect a single servo and re-assing the ID doesn't work neither
    • No servo shows up in the Dynamixel Wizard


    So questions:
    • How can I tell what's broken, OpenCM or servos? I have no other microcontrollers as fallbacks...
    • Is there any reflashing/reseting/re...whatever to the OpenCM or AX-12A? Of course I tried user and reset buttons, but didn't help
    • Maybe servos lost their ID somehow... If so, I cannot set it back because write operations fail
    • Should Dynamixel Wizard show the AX-12As connected to an OpenCM? Now finds 0
    • In case I broke the OpenCM, do you think an Arbotix is a better option? I use the OpenCM just because someone gave to me.


    Thank you very much!

  2. #2

    Re: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    Yes, you can re-flash the servos (and test the servos) with a USB2Dynamixel, or a USB2Ax device, and the Robotis Dynamixel Wizard software.
    You can also re-flash the OpenCM, although I forget exactly how. Perhaps you also use Dynamixel Wizard, and hold the button when turning on/plugging in the board?

    Should Dynamixel Wizard show the AX-12As connected to an OpenCM?
    With the right sketch/firmware, yes, the OpenCM can emulate a USB2Dynamixel.

    I would recommend spending the $10 for another OpenCM and $5 for the bag of connectors and some time with a soldering iron to solder them in, so that you can have a second OpenCM. This will both serve as a back-up if something breaks at a bad time, and let you debug this problem further.
    If you want to get into Dynamixel servos in more detail, too, I highly recommend the USB2Ax (or more bulky/expensive USB2Dynamixel.)

    Finally, I like the OpenCM better than the Arbotix, because it has a much faster CPU. However, it needs a little more soldering/integration than the Arbotix, which is more of a "ready made solution" for the things that the Arbotix is intended to do.

  3. Re: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    Thank you very much for your fast response. I guess you mean the tosser firmware. I tried with it, but still cannot detect the servos with the Dynamixel Wizard, nor recover the servos firmware (it detects nothing when I click SEARCH).

    I also tried restoring the OpenCM with Dynamixel Wizard -> RoboPlus Manager -> Controller Firmware Management, but can neither detect my OpenCM (so much less restore the controller)

    So my sad conclusion is that at least my OpenCM is somehow broken. I say somehow because is still puzzling that many things keep working fine: can run the firmware, and read the analogue ports! As you recommend, I'll buy a new one. For the USB2Dynamixel/USB2Ax, I don't want to tinker much with the sensors... I just want my arm back to life! So I'll first try with the new OpenCM and buy the USB2Ax if necessary to restore my servos.

    Btw, searching here for solutions to my problem I found this alternative library to control Dynamixel servos with the OpenCM. Do you have any information about weather it outperforms the Robotis software?

    Thanks again!

  4. #4

    Re: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    The Robotis software has some warts, but the difference probably won't be noticeable.

  5. Re: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    As I though... my OpenCM is broken. I got a new one and works as usual.
    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Acceleration implementation on OpenCM?
    By jomo in forum DYNAMIXEL & Robot Actuators
    Replies: 4
    Last Post: 05-19-2016, 08:18 AM
  2. Project Darwin-Mini project with OpenCM IDE
    By klims in forum Humanoids, Walkers & Crawlers
    Replies: 2
    Last Post: 05-01-2016, 10:50 PM
  3. OpenCM IDE (Ubuntu 14.04)
    By rasheinstein in forum Arbotix, Microcontrollers, Arduino
    Replies: 2
    Last Post: 04-12-2016, 01:47 PM
  4. Project OpenCM 9.04 - B and 18 Dynamixel AX-12A servos
    By OpenRobot in forum Power
    Replies: 2
    Last Post: 11-29-2015, 06:23 PM
  5. MX-64. Dead. Again.
    By jwatte in forum DYNAMIXEL & Robot Actuators
    Replies: 12
    Last Post: 06-25-2013, 11:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •