Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Attaching hobby servos stops AX-12A from working

  1. #11

    Re: Attaching hobby servos stops AX-12A from working

    Thanks for all the help in looking into this. I think the problem I faced just running the attach code and failed servo calls were due to a bad board. Using the same code and wiring on another (3rd board) and the code worked fine and was able to drive the servos and find the AX12As. This was using the built-in Servo.h library and not the HServo Arbotix one.

    Once that was working, I needed to go back to using VarSpeedServo in order to control the speed of the micro-servo movements. But then I ran into a problem with the timer interrupts because the servos were moving really, really slow. Seemed like the interrupts were conflicting with something else using it.

    I'm too novice to understand all the timer code, but the suggestion of using ports 12 and 13 were a good clue. I switched from using 12 and 14 to 12 and 13 and voila, the timing problem went away. So lesson learned is that the VarSpeedServo library seems to work on the Arbotix as long as you use pins 12 and 13.

    Thanks again!

  2. #12

    Re: Attaching hobby servos stops AX-12A from working

    Glad it is working. I would not necessarily give up on the other two boards. It may be simply you are just on the limits of the board and as such it may or may not work. So again if it were me I would maybe try HServo on the other two boards and see if it works... If not maybe need to ask Trossen more about it.

    Good luck

  3. #13
    LulaNord Guest

    Re: Attaching hobby servos stops AX-12A from working

    Hi...I'm new to Robots designing and using Arduino fo0r this. For me Smart Servo Shield for Arduino + Ax-12A servos work for me in "continous (rotation) mode", but I'm unable to control servo position in "servo mode". The problem is that I can only control servo velocity and when I change values for servo position, the servo start rotating CCW with defined velocity.

    printed circuit board
    Last edited by LulaNord; 09-22-2017 at 12:45 PM.

  4. #14

    Re: Attaching hobby servos stops AX-12A from working

    Have you written the register on the servo to make sure it is in position, not velocity, mode?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Servos not working
    By Harper in forum HR-OS1 Development and Discussion
    Replies: 3
    Last Post: 06-09-2015, 09:53 AM
  2. 6 external hobby servos in ArbotiX Analog inputs
    By dburongarcia in forum Arbotix, Microcontrollers, Arduino
    Replies: 3
    Last Post: 03-23-2013, 05:00 PM
  3. Hobby Servos: Disappointment strikes
    By jwatte in forum DYNAMIXEL & Robot Actuators
    Replies: 1
    Last Post: 10-20-2012, 01:24 AM
  4. hobby servos
    By mblackwolf in forum Mech Warfare
    Replies: 5
    Last Post: 10-19-2011, 07:52 PM
  5. How to deal with unexpected stops.
    By Resilient in forum Software and Programming
    Replies: 2
    Last Post: 04-01-2009, 08:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts