Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: PhantomX new build (18A), some tibia servos not working (one intermittently)

  1. Unhappy PhantomX new build (18A), some tibia servos not working (one intermittently)

    I just built a PhantomX with 18A servos and some the tibia servos are not being found while running the build check. I suspect not enough voltage is getting to them. Initially, it was #5, 6, 11 and 18 not found. Then I was getting the low voltage failure so I check every servo ID and range with Dynamanager and double checked all the wiring. Then I was getting #5 and 11 not found then 5 and 12 not found with 11 working. I have tried both 12v power adapter and battery and checked the voltage on the power adapter and it is good. Tomorrow, I will try another 12 volt power supply that will give more amps but if that works, it still doesn't help me run off the battery. Much thanks to anyone who has ideas on how to fix.

  2. #2
    Join Date
    May 2016
    White Plains, NY
    Rep Power

    Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    The 18A servos pull a lot of power. When using a 10A supply, and moving, I was often having low-voltage problems. I had to upgrade to a 30A supply.

    That being said, this should not be a problem if you're just doing the build-check. Servos 5, 6, 11, and 18 are all outer-most servos. Try pushing the connectors in tightly to all the servos in the legs. I suspect some are loose. The fact that you're having servo's drift in and out of accessibility leads me to believe you have connectivity issues. I've had this issue at various times.

  3. #3

    Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    Two things:

    1) You can actually "float" the 3S battery in parallel with the 12V power supply, as long as the power supply doesn't output anything more than 12V. (12.1V might be too much.) This will let you keep working with the power supply, but the battery will add "oomph" when power surges draw more current.

    2) It sounds like you either need to make sure the connectors are properly pushed into the servos, like Brooks says, OR you may have wires that are glitchy. It happens. If you have more wires (even of different length,) then perhaps try changing some around and see if the problem moves.

  4. Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    Thanks, I check all the servo connections and now I am getting "Voltage levels below 10v". I plugged in a 13.8v 11.5 amp power supply and same thing, low voltage. I also commented out the CheckVoltage() function call in the code and ran it and no servos are found. I looked for the servo LEDs on boot up and some of the tibia LED did not light so I pushed on the fully seated connector and the led came on. And then I did the same on another it came on every time I pushed on the connector. I think my cables are giving problems. Is there a source of high quality cables? Preferably copper. Maybe I should ask this question in a new thread?

  5. #5

    Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    Yes, you will get the "low voltage" warning if no servo is found, because the firmware uses the servo voltage sensor to read the voltage, and if no servo is detected, it will think there's no voltage.

    13.8V is too much for the AX series; they were initially designed for 9.6V NiMH batteries, and were then pushed to 12V / 3S for higher performance, but that's about the limit that works for them.

    The two sources of ready-made cables are Trossen (20 gauge, black connectors) and Robotis (22 gauge, white connectors.)
    You can of course also get silicone stranded wires and Molex connectors and pins and tooling and crimp your own, if you have the patience for it. (I don't :-) (there are also bundles of specific lengths.)

  6. #6

    Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    What code are you running? Low voltage warning, if Phoenix code could be because having issues reading Servo voltages reliably.

    These days I don't normally like to run with that turned on unless I have setup a resistor divider to measure the voltage using analogRead.
    I have a simple one I wired into a cable to plug into Arbotix-m board...

    But if the main issue is some of the servos not being found. I would also suspect that maybe one or more servos reset their id to #1, which causes problems a couple of ways. One is they all will move to same locations, plus the query of servo data including the voltage will fail...

  7. Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    Thanks jwatte. I am going to order the variety pack and see if I can swap out the bad cables. As an impatient dummy, I was pulling some connectors out by the wires instead of using needle nose on the connector. It would be rather disappointing if I got multiple failed cables from the factory. I am started to get concerned about the overall reliability of this cable setup for the PhantomX. I'll post what I discover when the new cables come in.

  8. #8

    Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    In the mean time, you might want to do some simple testing and observations. I am assuming your setup is Arduino using the Arbotix-m.

    like: When you first plug in power and/or turn on the switch, do all of the servos blink once? If so you know that they all are getting power...

    What is your software setup? Are you using the old Arduino 1.0.6 setup or are you trying the more recent Arduino release setup, as mentioned in the thread:

    I am assuming the old version 1.0.6. You might try running my test program, which you can download from:

    Note: I recently added the branch for the 1.0.6. With this once you use the FTDI cable to upload the program to the arbotix.
    You should be able to open up the Serial monitor. You need to setup the correct comm port, baud rate 38400 and the line ending probably to both (cr and lf)

    Again this is a semi stupid collection of things that I found useful to check things out and in some cases fix. There are real simple commands, which often are one letter or number and sometimes with one or more parameters... Other programs can do this as well.

    If you do the 4 command: it will try to find the current position of all of the servos of a hexapod (or quad if configured).
    Note: This program defaults to assuming what I changed on my robot and what was Servo #1 is now #19, such that the Phoenix code can try to detect if a single servo resets it's id to #1, it can try to renumber it back to the right servo number...
    You can have it not look for #19 and instead #1 by commenting out: #define SERVO1_SPECIAL 19
    If you see several with bogus values and retry you know it did not find some of them.

    Another command I try is: 1
    It will set the torque on for all of the expected servos and set their positions to mid point (512). I typically have my hex up on some stand (currently mixed nut jar from costco). All of the servos should lock in with legs pointing straight out and then pointing down... You can then try to move some of the servos to see which ones are not on... After this I might enter the command: 0
    that will release the torque from all of the servos...

    A way to see if multiple servos are now logically servo #1 is to use the command: 3
    Something like: 3 1 400
    Which should move servo number 1 to 400. If multiple servos move you know that some servos have reset their ID... Or in my case if any move as by default I don't have any servo #1...

    If you find some servos that are number 1 that should not be, you can use the 8 command to set a servo id:
    like: 8 1 5

    But this will set all servos who are now #1 to #5... So before doing that, you try to disconnect all of the other servos with #1. If multiple ones are like this you may have to repeat, unplugging some wires and plugging in others... Often if you do it in a reasonable order after you fix the first one you simply plug in more cables to get to the next bad #1...

    Sometimes I use the command 5:
    Which simply iterates over servo ids 1-253 trying to ping them and if it finds something it shows the servo numbers it found

    Again this may not find anything if the wires are bad or if not enough current, but may find out if it is some other simple issue...

  9. Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    Thanks KurtEck. When I power up, many of the tibia servos do not blink until I push on various places on the cable or that servo's connector which leads me to think it is the cables. I am running Arduino 1.0.6 HexapodTest and currently servo's 5, 6, 11, 17 and 18 are not found. I just tried again and now I am getting "System Voltage: -.10 volts...". It's odd that sometimes I get the voltage message and sometimes HexapodTest runs and indicates the missing servos and moves all the Coxa and Femur servos just fine and other times it boots up and can't find any servos. I know at a minimum, I need to get some new tibia cables and get all the servos LED blinking on power up. Then, tackle any remaining issues.

  10. Re: PhantomX new build (18A), some tibia servos not working (one intermittently)

    Thankfully, Trossen promptly sent new cables which fixed all the tibia servo problems. Now, I am have some other intermittent problem which I believe is board power related so, I will do some troubleshooting and forum searching. I am controlling from the Commander and everything works great in 1 out of every ~5 power ups. One question, has anyone directly wired power to both boards (arbotix-m and power hub) in parallel? Should be a non issue, common ground right? The reason being, I don't like the idea of all my front leg servo power and main board power being pulled over the one little wire from the power hub especially with 18A servos.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question(s) Attaching hobby servos stops AX-12A from working
    By gmui in forum Arbotix, Microcontrollers, Arduino
    Replies: 13
    Last Post: 04-11-2017, 05:01 PM
  2. Servos not working
    By Harper in forum HR-OS1 Development and Discussion
    Replies: 3
    Last Post: 06-09-2015, 09:53 AM
  3. PhantomX Robot Turret AX-12A assembled working.
    By akumadog in forum Garage Sale
    Replies: 1
    Last Post: 09-06-2013, 02:16 AM
  4. Question(s) PhantomX Hexapod New old Tibia Frame
    By hwan we in forum Robotics General Discussion
    Replies: 2
    Last Post: 02-14-2013, 11:33 AM
  5. Problems getting the PhantomX Hexapod and Quadrupods working
    By GordoTheHat in forum Humanoids, Walkers & Crawlers
    Replies: 3
    Last Post: 01-26-2012, 05:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts