Results 1 to 10 of 10

Thread: Usb2ax bsod

  1. Usb2ax bsod

    Hi folks,
    I have a quite wired error. I want to use USB2AX for my dynamixel (MX-64) which I use via DMX SDK in C#.
    Everything works fine for simple motion. However, after 30-60 seconds, I sometimes get a blue screen wit "driver_irql_not_less_or_equal" causd by "usbser.sys".
    I had a look at the USB2AX FAQ and learned that this happens frequently to labVIEW users and that the issue could be resolved by switching from asynchronous to synchronous mode in labVIEW. However, I could not find anything about this error or mode using C# SDK.

    Would be huge help if someone could help me resolve this essential problem. I hope someone has experience with that.
    Thank you

  2. #2

    Re: Usb2ax bsod

    Sorry, maybe others can answer this better.

    Might help to have additional information. From blue screen I am assuming Windows. Which version?
    Note: There were many issues associated with USB that were improved on Windows 10. For example many devices (like Teensy processors by PJRC) no longer require driver files. I would guess this is true for USB2AX.

    I would probably check to make sure your driver files are up to date.

    As for Async vs Sync... Not sure, I am not a c# person... Mostly C/C++.

    Again hopefully someone else can give you some additional suggestions.

  3. #3

    Re: Usb2ax bsod

    usbser.sys is the Windows serial USB driver. If that bluescreens, then Microsoft has a bug. It should not ever crash the kernel, even if the hardware misbehaves.
    You might want to talk to Microsoft about getting support for your version of Windows, if you paid for it. (I think Windows is great, but when I run into problems like this in Linux, I can just pull out the source and fix it myself ...)

  4. Re: Usb2ax bsod

    Hi,
    thanks for your ideas. A little update:
    I plugged the usb2ax to a usb 3.0 just to double check that it is not due to bower lack. Did't help.
    I use windows 7 Enterprise. Ill now try it on a different PC with windows 10 to see whether there is a difference. Ill keep you updated.

  5. Re: Usb2ax bsod

    Hi,

    Things like that happen from time to time to some people (<1% of users), and so far I haven't been able to reproduce nor to get any insight on what was happening. It's quite infuriating to be honest, for me and even more for users who experience it.
    It will work on a computer and fail all the time on another one with the same hardware and extremely similar software (think university lab, where identical machines are bought many at a time and OS is installed in batch).
    One thing to test if you have the possibility is to use a USB isolator (like USB), to rule out electrical problems. For some it removed the problem completely, for others it did not make any difference.
    You could also try, if you have the parts availalbe, to just add a 10uH inductor on the ground lead, between the USB2AX and the servos. The USB2Dynamixel has one, and it's not subject to these BSOD (different driver though, so no concrete proof that it has any link with this problem).

    I can refund the USB2AX too if nothing works.

    Hope that helps.
    ---
    Personal blog: http://xevel.org
    USB2AX documentation: http://xevelabs.com

  6. Re: Usb2ax bsod

    Hi Xevel,
    first of all, I'm very happy to hear that I'm not the only individual on this planet facing that problem. Also, "infuriating" is just the right expression to describe my feelings about the project. Since things like changing the USB port did not help at all, I will now try to apply what you suggested. Ill keep u updated

  7. Re: Usb2ax bsod

    Just a follow up, which might help a few people:

    https://groups.google.com/forum/#!to...rt/8yo95VYLdFM

    The serial driver from National Instruments has two modes, synchronous and asynchronous, and apparently when it's in asynchronous (the default) mode, it can lead to this result of a BSOD. Changing the driver to synchronous mode seems to fixe the problem.
    ---
    Personal blog: http://xevel.org
    USB2AX documentation: http://xevelabs.com

  8. Re: Usb2ax bsod

    Hi Xevel,
    I tried what you suggested earlier about the USB isolator. Sadly, it didn't change anything though.
    Now about your hint above. According to the referenced conversation, it looks like the option can olnly be changed in LabView. However, i'm not using that. I think it is most likely, that the source of the error is the same. So now the question is, how the switch from asynchronous to synchronous mode can be done in a non-LabView setting. do you have any information about that?

  9. Re: Usb2ax bsod

    Hi,

    Unfortunately, none.
    What might be interesting would be to see if you have the offending driver though.

    Could you run in cmd.exe this command :

    driverquery /V > usb_drivers.txt


    then put the output in a pastebin for me ?
    ---
    Personal blog: http://xevel.org
    USB2AX documentation: http://xevelabs.com

  10. Re: Usb2ax bsod

    embedding failed but this is the link:
    https://pastebin.com/embed_js/itvC4J8P

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. USB2AX and ROS
    By dejamzo in forum ROS - Robot Operating System
    Replies: 4
    Last Post: 10-19-2015, 07:51 PM
  2. Udoo + usb2ax
    By Gertlex in forum Arbotix, Microcontrollers, Arduino
    Replies: 8
    Last Post: 05-10-2014, 11:16 PM
  3. DynamixelSDK for USB2AX
    By Xevel in forum Software and Programming
    Replies: 1
    Last Post: 02-25-2014, 02:02 AM
  4. USB2AX v3.0a feedback
    By Xevel in forum Arbotix, Microcontrollers, Arduino
    Replies: 65
    Last Post: 11-15-2013, 05:49 PM
  5. USB2AX v3.1
    By Xevel in forum Arbotix, Microcontrollers, Arduino
    Replies: 25
    Last Post: 04-08-2013, 02:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •